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INTRODUCTION
Scientific Toolkit for Opensees (STKO) User Manual comprises all essential and practical
information for the customer to use this software. This manual contains a description of
functions and capabilities from preprocessing till postprocessing phase, including procedures
for meshing, analysis and also an introduction to customization. The format of the manual
may be updated for latest STKO version.

What is STKO?
STKO is a cutting-edge complex data visualization tool for Opensees. By using STKO a user can
create a Tool Command Language (TCL) input file for Opensees and after processing read the
output file and data through its graphic interface. Here are presented the adopted HDF5
database library, the structure of the proposed file format, the Python-based scripting
interface for manipulation and customization of results and also the implementation of the
new recorder class in OpenSees.
webpage: www.asdeasoft.net/stko

Figure 1. STKO examples
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1. Get Started - STKO User Interface

STKO user-friendly interface enables users to easily understand how to manage models with
easy and full control. The program includes two modules: the Pre Processor module and the
Post Processor one.

1.1. User Interface (How to Navigate)
Here is introduced the pre-processing and post-processing module double interface of STKO
and how to interact with it. Some items are presented in both modules of STKO. The following
examples are from the postprocessing one.
Software’s interface is divided into 7 sections (Figure 2):
(1) Pre and Post Processor interface
(2) Main Toolbar
(3) Work Tree window
(4) Terminal window
(5) Editor window
(6) Quick access window
(7) Render view

Figure 2. STKO Interface.
(1) Pre and Post Processor interface. The working context can be selected by the user in
the upper right of the window.
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Figure 2. Pre Processor Toolbar

Figure 3. Post Processor Toolbar

(2) Main Toolbar. This Toolbar organizes and displays tools by task.

Figure 4. Main Toolbar

(3) Work Tree. The Work Tree contains all the hierarchical information about the models.

Figure 6. Post-Processor Work Tree

Figure 5. Pre-Processor Work Tree

In the Pre Processor Work Tree user can move previously created items to list them in the
correct order even if they were created later. The up and down arrows allows user to move
them along the work tree.
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SCROLL ARROWS

Figure 7. Before the moving of a previously created item

Figure 8. After the moving of the item

(4) Terminal Window. This Window contains two text editors. The first one shows the
software commands output while in action. The second one is the Input bar, which provides a
fast way to enter commands; coordinates and values directly using the keyboard. Input bar
also has an auto compilation feature (Figure 12)

Figure 9. Software output

Figure 10. Input user

Figure 11. Example of auto compilation command

(5) Editor Window. This window shows all features related to the object selected in postprocessor module: information, surface color map, color map, visualization.
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Figure 12. Editor window

(6) Quick access Toolbar. This toolbar gives the possibility to set views, grid, zoom, show
vertices, edges and surfaces.
Grid

Perspective

Views

Parallel

Osnap

Figure 13. Quick access toolbar

Zoom

Select/Unselect elements

Show/Hide elements and local axes

(7) Render window. This window shows the model and its features.

Figure 14. Render window
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1.1.1. Keyboard & Mouse Commands
Mouse Wheel Hold down: it pans the view in the space.
Scroll Up: scrolling the mouse wheel up will zoom the object in.

Scroll Down: scrolling the mouse wheel down will zoom the object out.

Right-Click: the right mouse button click enables user to repeat a previous command.

Mouse Wheel + [Ctrl]: Holding the mouse wheel + Ctrl down and moving the mouse will
rotate the view around the object.
[Canc]: it deletes the selected objects.
[Esc]: It deselects all selected objects.
[Ctrl]+[Z]: The equivalent of UNDO.
[Ctrl]+[Y]: The equivalent of REDO.
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1.1.2. Gesture Commands
STKO enables users to use touch screen commands (or gestures) if the computer has this feature.
Fingers may use any of these tricks:
Move: Place two fingers on the screen and then move them to move the view around the
object.
Zoom in & Zoom out: simply use two fingers and pinch them inwards (to zoom out)
or pinch them outwards (to zoom in).

Tap: The equivalent of a mouse Click. It enables users to select single objects on the
interface.

Ctrl+Tap: The equivalent of a mouse Click + Ctrl. It is used to unselect single objects on the
interface. To unselect multiple objects, use one finger to double tap and drag from right to
left holding the Ctrl Key down.
Crossing Selection: To imitate the mouse’s selection, simply use one finger to double tap
and drag from right to left to select all objects that are crossed by the selection rectangle.
Window Selection: To imitate the mouse’s selection, simply use one finger to double tap
and drag from left to right to select all objects that are entirely enclosed in the selection
rectangle.
Rotate to turn: Hold down one finger on screen and rotate it in a circular motion either
clockwise or counterclockwise.
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1.2. Handling Selection
User can easily select more than an element of the geometry by using some Quick access
toolbar commands above the render window.

vertices

edges faces solids all interaction

Figure 15. Handling Selection Toolbar

Otherwise, geometries can be quickly selected in the Work Tree where all the model’s
geometries are listed under the item Geometry. By clicking on the item, a subgroup of
entities will appear under geometry in order to select not only the whole geometry but also
each element that made it up.

Subgroup of “Lines”
Subgroup of “Lines”
Subgroup of “Interaction”
Figure 16. Work Tree

Obviously, some commands (such as Loft, CAD commands, etc…) do not permit a multiple
selection. For this reason meanwhile using them the selection command in the Quick Access
Toolbar will be turned off.
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1.3. Create, Edit and Save Pre and Post Processor Documents
To Create a New document or Open an existing one, user can choose the corresponding
commands in pre-processor interface:

Figure 17. Home section in the Pre Processor main Toolbar

To save the current document select from the main Toolbar: Home > Save. Click Save as to
save the current document to a new location use. If the current document has never been
saved before, Save command will automatically call the Save as command to name file for
the first time. The file extension is .scd (STKO CAE Document).
The post-processor interface stores data such as: loaded output databases, plots, charts
ex.… The file extension is .sped (STKO Post-Processing Document). Like in pre-processor
interface select from the Toolbar: Home > Save to save the current document. Use Save as to
save the current document to a new location. If the current document has never been saved
before, Save command will automatically call the Save as command to name the file for the
first time.
To Open an existing DB (database), Reload or Close DB click on corresponding commands:

Figure 18. Home section in the Post Processor main Toolbar

The program let load more than a single Database in Post-Processor Section and more than
one between Plots and Plot Groups, charts and its data. Whenever user would open a saved
post-processor document, it will include .mpco files with Plot Groups and Charts created by
user without losing data.
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Figure 19. Post-Processor Work Tree of a Structure

User can choose between different kind of Plots (Deformed Shape, Surface plot, Volume plot,
Beam/Shell Fiber plot, Gauss Point Plot). With right-click on Plot Groups > New Plot Group >
right click on New Plot Group and choose which Plot needs to be shown. Select on Plot and
see all data i.e.: Information, Data, Color Map and Visualization can be set on the Editor Panel.
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Figure 20. Example of Surface color map

To Delete a New Plot Group or a single Plot click with the right mouse button on the
corresponding item and select Delete Plot (or Plot Group). (see § 3-3.2 Post processing
module)
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2. Preprocessing Module
By using pre processing module a user can create input file for OpenSees, starting from CAD
modeling until algorithms definition, in order to create a Tool Command Language (TCL) file
with all information required by OpenSees to solve it.
From CAD toMesh

Solver

OpenSees
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2.1. Geometry
In STKO, the definition of Geometry is divided into eight sections: Exchange, Edit, Sets, Points,
Curves, Surface, Solids and Boolean. Those are both arranged in the geometry drop-down
menu and in the main Toolbar, like every STKO features.

Figure 21. Geometry drop-down menu

Figure 22. Geometry main Toolbar

Viewport and viewport projection
Before starting, it is better to highlight the possibility for the user to specify the design plane.
By clicking on view cubes from the Quick Access Toolbar user can choose on which view he
wants to operate (above, bottom, front, back, left and right side). Each view can be seen
alternatively in parallel and perspective projection. In a parallel view, all the grid lines are
parallel to each other, and identical objects look the same size, regardless of where they are in
space. In a perspective view, grid lines converge to a vanishing point. This provides the
illusion of depth in the viewport. Perspective projection makes objects farther away look
smaller. Click on axonometric cube to have an axonometric projection.

Figure 23. Quick Access Toolbar
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Workplane
STKO give the user the possibility to specify the construction plane.

Figure 24. Workplane in the Document main Toolbar

Workplane 3 points
By the Workplane 3 points command user can set the origin and orientation of
the construction plane. Click on Document > Workplane 3 points. In addition,
user can manually specify new workplane 3 points or type x y and z (optional)
coordinates after the origin.
Workplane parallel
By the Workplane Parallel command user can set the origin and orientation of the
construction plane. Click on Document > Workplane Parallel and offset the Work
Plane along using plane. Through this command the user can set the work plan and
change the Cartesian references, in order be able to work in different points of the work area.
After creating workplanes user can save each created plan, choose and controls them directly
from the Work tree where are listed and select one of them whenever needed.

Workplane Offset: 30

Figure 25. Workplane settings
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2.1.1. Geometry – Exchange
The commands present in Exchange section are a subset of the Geometry category. Each
one allows the user to import or export geometries from one or to other files.

Figure 26. Exchange section in the Geometry drop-down menu

Figure 27. Exchange section in the Geometry main Toolbar

Import
Geometry > Exchange > Import
1. Click Import from Geometry > Exchange menu.
2. Input geometries from file.
After enabling the command select the file path from the interactive menu. The supported
files extensions are IGES Files (*.iges, *.igs), STEP Files (*.stp *.step), BREP Files (*.brep
*.rle). A window of Regenerate Model will appear:

Figure 28. Window of Process status

STKO
18

Terminal bar shows all geometries that user selects:

Figure 29. Example of a meshed soil-modeling

Export
Geometry > Exchange > Export
1. Click Export from Geometry > Exchange menu.
2. Export geometries to another file.
After enabling the command select the file path from the interactive menu. The supported
files’ extensions are IGES Files (*.iges, *.igs), STEP Files (*.stp *.step), BREP Files (*.brep
*.rle).
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2.1.2. Geometry – Edit

The commands present in Edit section are a Geometry category subset. Each one allows the
user to make a specific changement to the geometries. To perform transformation user must
select one or more geometries through Left-Click and then Right-Click to enable selection.
Press [Esc] on keyboard or select it through Right-Click to abort a command while in use.
Note: All commands can be alternatively realized by typing their name in the Terminal input
bar, which also has an auto compilation module,and following the instruction given.

Figure 30. Edit section in the Geometry drop-down menu

Figure 31. Edit section in the Geometry main Toolbar
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Delete
Geometry > Edit > Delete
1. Click Delete from Geometry > Edit menu.
2. Select geometries.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3. End.
Press the [Enter] on the keyboard or the Right-Click to terminate the function of the
command.

Query Geometry
Geometry > Edit > Query
1. Click Query Geometry from Geometry > Edit menu.

Figure 32. Query properties window_Selection part

Figure 33.Query properties window_Properties part
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An editing window will appear. In selection part (Fig. 32) user can select geometries to query
by hierarchy, by mass property or by location. Once defined the geometry to query user can
know its properties like length; area; volume; face-edge-solid center of mass or coordinates
to points. (Fig.33).
2. Select geometry.
User can choose geometry selecting it dircetli with mouse or by the selection window. After
confirmation, the selected geometries will turn red.
3. Select properties.
After selecting geometries user can switch to properties window and know length, area,
volume and some other informations.
3. End.
Press the [Esc] on the keyboard or the Right-Click to terminate the function of the command.

Move
Geometry > Edit > Move
This command moves geometries in another position in space. The action is completed only
by two points (the first and the second point of translation). The user can specify through
mouse or keyboard the first and second point of the distance, defining the translating line,
to move the objects.The Terminal Input accepts to enter the X Y Z coordinates, i.e.: (100 -100
0) and eventually the distance value, i.e.: (100.5) after the first point (he Z coordinate is
optional, by default it is set to 0).

1. Click Move from Geometry > Edit menu.
2. Select geometry.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3. Specify the first point.
Click anywhere in work plane or on a point belonging to the geometry or type coordinate
X Y Z to assign a reference point.
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4. Specify the second point.
Click in work plane or type coordinate X Y Z or type the distance value to define the
move.
6. End.
Press the [Esc] on the keyboard or the Right-Click to terminate the function of the
command.

Copy
Geometry > Edit > Copy
This command copies geometries in another position in space preserving their features. The
action is completed only by two points (the first and the end point of translation). The user
can specify through mouse or keyboard the first and second point of the distance, defining
the translating line, to copy the objects. The Terminal Input accepts to enter the X Y Z
coordinates, i.e.: (100 -100 0) and eventually the distance value, i.e.: (100.5) after the first
point. The Z coordinate is optional, by default it is set to 0. After generating the first copy, the
command remains active in order to create other copies of the same geometry. The action
ends by pressing [Enter] on keyboard or with a Right-Click.
1. Click Copy from Geometry > Edit menu.
2. Select geometry.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3. Specify the first point.
Click anywhere in work plane or on a point belonging to the geometry or type
coordinate X Y Z to assign reference point.
4. Specify the second point.
Click in work plane or type coordinate X Y Z or type the distance value to define the
position of the copy.
5. Specify the next point.
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In case you want to generate more copies of geometry, continue to click in work plane or
type coordinate X Y Z or type the distance value to define the position of the copy.
6. End.
Press the [Esc] on the keyboard or the Right-Click to terminate the function of the
command.

Rotate
Geometry > Edit > Rotate
The command rotates or alternatively generates a rotate copy of the selected geometries. It
works around a point as center of rotation in a plane 2D, of an angle in relation to a normal
axis of the plane. The action is completed by three points. The user can specify through
mouse or keyboard the first point, defining the center of rotation; the second point, as a
temporary reference line and the third point, as reference to define the value of the
rotation angle. The textual dialogue interface of the Terminal defines the rotation the
geometries. The Terminal accepts to enter the X Y Z coordinates, i.e.: 100 -100 0, for the three
points after selection. The Z coordinate is optional, by default it is set to 0. Eventually, the
Terminal accepts the distance value, i.e.: 50, to build the reference line and the angle value,
i.e.: 90, to define the rotation angle after the insertion of the second point.
After generating the first copy of rotation, the command remains active in order to insert new
copies. The action ends by pressing the [Enter] key or through the Left-Click. At the end of
the command the starting geometry, remain selected. The user can decide to delete or leave
the object.
1. Click Rotate from Geometry > Edit menu.
After clicking Rotate a setting window will appear. User has to choose
between Transform the selected object or create a transformed Copy of it.
2. Select geometry.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3. Specify the first point, center of rotation.
Click anywhere in work plane or on a point belonging to the geometry or type coordinate
X Y Z to assign a reference point for the center of rotation.
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4. Specify the second point, temporary reference line.
Click in work plane or type coordinate X Y Z or type the distance value to define a
temporary reference line.
5. Specify the third point, rotation angle (degrees) or reference point.
Click in work plane or type coordinate X Y Z or type the angle value to define the rotation
angle.
6. Specify the next point.
In case you want to generate more rotated copies of geometry, continue to click in work
plane or type coordinate X Y Z or type the incremental angle value to define the
position of the rotated copy.
7. End.
The action ends by pressing the [Enter] key or through the Left-Click.

Figure 34. Rotating operation_part one

Figure 35. Rotating operation_part two

Scale
Geometry > Edit > Scale
The command changes geometries size in relation to one, two or three dimensions. To
activate the action, choose the command from the Toolbar or Menu and select the geometries.
After activation, a menu is displayed for choosing the type of scale (1D, 2D, 3D – Uniform
scale). The Scale1D command changes the size of selected objects in one direction, the
Scale2D changes the size in two directions and Scale3D changes the size of selected objects
uniformly in the x, y, and z directions
1. Click Scale from Geometry > Edit menu.
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2. Select the type of scale.
After enabling the command an interactive menu is show on the screen
with the scale parameters. Select the desired type of scale: 1D, 2D, 3D –
Uniform scale.
3. Select geometry.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
4. Specify the reference base point.
Click anywhere in work plane or on a point belonging to the geometry or type coordinate
X Y Z to assign a reference base point for the scale.
5. Specify the scale factor.
Type the value of scale factor to create a new scaled object and press [Enter] and the
command is done. In case the on-screen graphic reference is preferred follow the next
passeges instead of the step (5).
6. Specify the second point, unitary measure of reference.
Click in work plane or type coordinate X Y Z to define the reference measure.
5. Specify the third point, value scale factor.
Click in work plane or type coordinate X Y Z to define the value scale factor.

Figure36. Example of the Scale command
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Mirror
Geometry > Edit > Mirror
The command reflects or alternatively generates a specular copy of the selected geometries.
The transformation obtained is an axial symmetry of the selected geometry. To activate the
action, choose the command from the Toolbar or Menu and select the geometries. The action
is completed by two points, the first and second point to define the temporary line as axis
of symmetry. User can specify through mouse or keyboard the first and second point
defining a line that identifies the axis of symmetry to copy and to mirror the objects. The
Terminal accepts to enter the X Y Z coordinates, i.e.: 100 -100 0 and eventually the distance
value, i.e.: 100.5, after the first point to define the temporary line used as axis of symmetry.
The Z coordinate is optional, by default it is set to 0. At the end of the command the starting
geometry remain selected. The user can decide to delete or leave the object in work plane.
1. Click Mirror from Geometry > Edit menu.
After clicking Rotate a setting window will appear. User has to choose
between Transform the selected object or create a transformed Copy of it.
2. Select geometry.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3. Specify the first point.
Click anywhere in work plane or on a point belonging to the geometry or type coordinate
X Y Z to assign a first reference point.
4. Specify the second point.
Click in work plane or type coordinate X Y Z or type the distance value to define the line
to construct the axis of symmetry.
5. Close the action.
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Figure 37. Mirror command activation

Figure 38.Mirror command in action

Explode
Geometry > Edit > Explode
The command identifies the subclasses of the object splitting it in its component objects. A
complex object can be divided into simpler parts by applying it. For example, a parallelepiped
can be splitted into its made up basic geometries like vertices, edges, faces. To activate the
action, choose the command from the Toolbar or Menu and select the geometries.
The user can select through mouse one or more geometry and Right-Click to enable the
action of the command explode.
1. Click Explode from Geometry > Edit menu.
2. Select geometry.
Click on any point belonging to the geometries to enable selection. After confirmation, the
selected geometries will turn red.
3. Explode.
Press the [Enter] key or the Right-Click to confirm the command. After confirming, the
geometry will be exploded.
4. Close the action.
The subdivided geometry remains editable. Press the [Esc ] key to preserve the geometries
in work plane or select via mouse the geometries onwhich to apply new actions.
Repeat the flow to obtain more subdivisions.
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Make Compound
Geometry > Edit > Make Compound
The command realizes a compound of the selected geometries. Making compound of curve,
surface or a solid creates a "composite" geometry made up by different items which preserve
their own geometrical features. i.e. this command provides to join different geometries
without changing their properies and their subclasses. For example, two distinct solid
parallelepipeds, after the selection and application of the command, will result in a single
compound object having the subclasses present in the two starting solids grouped and not
divided. To activate the action, choose the command from the Toolbar or Menu and select the
geometries.
The user can select the geometries to wich to apply the function of compound and finalize
the command by pressing the Right Mouse Button.
1. Click Make Compound from Geometry > Edit menu.
2. Select geometries.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3. End.
Once selected the desired number of geometries press the [Enter] on the keyboard or
Right-Click to terminate the command. The geometries will be composed after confirming.

Make Compound:
13 vertex
24 edges
8 faces
1 solid

Figure 39.Example of Compound

COMPOUND – a group of any type of topological objects.
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Make Wire
Geometry > Edit > Make Wire
The command creates a unique geometrical entity from two or more curves i.e . a polyline.
The procedure to follow to build the wire from the selected edges is intuitive. To activate the
action, choose the command from the Toolbar or Menu and select the geometries.
The user can select the geometries on which apply the Make Wire function and finalize the
command by Right-Click.
1. Click Make Wire from Geometry > Edit menu.
2. Select geometries.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3. End.
Once selected the desired number of geometries press the [Enter] on the keyboard or
Right-Click to terminate the command. A polyline will be composed after confirming.

Line 2
Line 1

Figure 40. Before making wire- 2 lines

Polyline

Figure 41.After making wire -1 polyline
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Sew Faces
Geometry > Edit > Sew Faces
The command creates a unique face from two or
more faces of starting objects. To activate the action,
choose the command from the Toolbar or Menu and
select the geometries. After activation, an interactive
menu is displayed to select the useful parameters.
The user can set: the value of sewing tolerance, by
default set to 1e-06; enable the cutting of free edges
and to generate non-multiple elements.
The user can select the geometries to wich to apply the function of Sew Face and finalize
the command by Right-Click, after selection parameters.
1. Click Sew Faces from Geometry > Edit menu.
2. Select the parameters of sewing.
After enabling the command an interactive menu is show on the screen with the
parameters. Define the sewing tolerance, by default the value is set to 1e-06. Select
whether to enable: cut free edges and allow no manifold.
3. Select geometries.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
4. End.
Once selected the desired number of geometries press the [Enter] on the keyboard or
Right-Click to terminate the command. After confirmation, the geometries are sewing.

Sweep
Geometry > Edit > Sweep
The command creates a geometry starting from a profile curve moving along a rail in order
to create an object. The starting curve - profile shape - defines the surface cross-section and
the rail - spine shape - defines the trajectory of the sweep. In this way different categories of
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geometries can be obtained. In reference to a generic line track, vertices generate edges;
edges generate faces; a face generate solid; wire generate shell and shell generate compound
solid. A solid and a compound solid can not be extruded. Choose the command from the
Toolbar or Menu and select the geometries to activate the action. The textual dialogue
interface of the Terminal specifies ways to sweep the geometries. The user can select, for first,
the geometry class of interest, as profile shape to sweep and for second the reference
geometry, as spine shape.
1. Click Sweep from Geometry > Edit menu.
2. Select the first geometry, profile shape to sweep.
Click on any point belonging to the geometry or on a subclass (vertice, edge, face, wire and
shell) to sweep. After click selection, the geometry turns red. Right-Click to enable the
function.
3. Select the second geometry, spine shape.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
4. End.
Press [Enter] on the keyboard or Right-Click to terminate the command. After
confirmation, the command ends generating a new geometry.

Figure 42.Example of sweep.
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Extract
Geometry > Edit > Extract
The command let extract simple geometries from complex geometries.
1. Click Extract from Geometry > Edit menu.
2. Select the geometry where extract from.
3. Select the geometry to extract. Click on any point belonging to the geometry or on a
subclass (vertice, edge, face, wire and shell) to extract. After click selection, the geometry turns
red. Right-Click to enable the function.
4. End.
Press [Enter] on the keyboard or Right-Click to terminate the command. After confirmation,
the command ends generating a new geometry.

Extrude
Geometry > Edit > Extrude
1. Click Extrude from Geometry > Edit menu.
2. Select the geometry, profile shape to extrude.
Click on any point belonging to the geometry or on a subclass (vertice, edge, face) to
extrude. After click selection, the geometry turns red. Right-Click to enable the function.
3. Define the height extrusion.
Click in work plane or type coordinate X Y Z or type the distance value to define the
height extrusion of the geometry in input.
4. End.
Press [Enter] on the keyboard or Right-Click to terminate the command. After
confirmation, the command ends generating a new solid.
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Defeaturing

This command involves removing one or more faces from the surface and a consequent
repair of it, replacing the removed part with itsapproximation or approximation of faces
connected to it. An example may be the replacement of a beveled angle with a sharp angle or
the removal of a hole with consequent modification of the face in order to plug the hole.
Geometry > Edit > Defeaturing
1. Click Defeaturing from Geometry > Edit menu.
2. Select the geometry to defeature.
Click on any point belonging to the geometry or on a subclass (vertice, edge, face) to
defeature. After click selection, the geometry turns red. Right-Click to enable the function.
The geometry will restore its initial state like the e.g:
3. End.

Figure 43.Geometry before the defeaturing

Figure 44.Geometry after defeaturing
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Repair fix

This command fixes model geometries problems like for instance face with missing steam
edge, wrong orientation, self-intersecting wire or lacking edge. Repair fix adapts shapes so as
to make them as appropriate for use in STKO. The user can set: the value of fix tolerance, by
default set to 1e-06 and which elements to fix like global, faces, solids and some other items.

Geometry > Edit > Repair fix
1. Click Repair Fix from Geometry > Edit menu.
2. Select the geometries to repair fix.
Press the Right Mouse Button to confirm the command. Terminal bar shows all repaired
geometries:

Figure 45. Terminal bar after RepairFix command

3 End.
Press [Enter] on the keyboard or Right-Click to terminate the command.
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Reverse

This command displays the normal-direction of a geometry or surface and let you invert it.
User can see geometries normal-direction arrows by activating the command Show/Hide local
axis on the Quick Access Toolbar. Surface normals are represented by arrows perpendicular
to the surface, and the u- and v-directions are indicated by arrows pointing along the surface.
Closed surfaces always have the surface normals pointing to the exterior. Obviously this
operation is not available for solids.
Geometry > Edit > Reverse
1. Click Reverse from Geometry > Edit menu.
2. Select the geometries to revert.
Click on any point belonging to the geometry or on a subclass (vertice, edge, face) to
extrude. After click selection, the geometry turns red. Right-Click to enable the function.
3. End

Figure 47. Surface with z-axis reversed up

Figure 46. Surface with z-axis down
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2.1.3. Geometry – Sets

Figure 48. Set section from the Geometry drop-down menu

Figure 49. Set section in the Geometry main Toolbar

Geometry Sets
Geometry > Sets > New
1. Click New from Geometry > Sets menu.
2. Select the geometry to add to the selection set.
Click on any point belonging to the geometry or on a subclass (vertice, edge, face) to add to
the selection. After click selection, the geometry turns red. Right-Click to confirm and to
name the selection set.
3. Add/remove geometry from selection set
Right-Click on the selection set from the Work Tree > Add to selection set > click on
geometries to add. Right-Click to confirm the selection.
Right-Click to the selection set from the Work Tree > Remove from selection set > click on
geometries to remove.
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2.1.4. Geometry – Points

Figure 50. Point section in the Geometry drop-down menu

Figure 51. Point section in the Geometry main Toolbar

Point
Geometry > Points > Point
1. Click Point from Geometry > Points menu.
2. Specify point.
Click anywhere in work plane or type coordinate X Y Z to assign the point.
3. End.
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2.1.5. Geometry – Curves
The commands present in Curves section are a Geometry category subset. Every command
allows to generate a specific geometric shape in the plane. To generate the desired shape
select in Toolbar the relative command and follow the indications shown in the textual
dialogue interface of the Terminal for the insertion of the construction steps.

Figure 52. Curve section in the Geometry drop-down menu

Figure 53. Curve section in the Geometry main Toolbar

Lines
Geometry > Curves > Lines
1. Click Lines from Geometry > Curves menu.
2. Specify the first point.
Click anywhere in work plane or type coordinate X Y Z to assign the first point of line.
3. Specify the second point.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure of segment to assign the second point of line.
4. Specify the next point.
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In case you want to generate a polyline continue to click in work plane or type coordinate
X Y Z or type the scalar value of segment to define the position of point.
5. End.
Once entered the desired number of points (Vertices) and lines (Edges) of geometry to
terminate the function of the command press the [Enter] key or Right-click.

Spline
Geometry > Curves > Spline
The command creates a spline in the space. To activate the action, choose the command from
the Toolbar or Menu and select the geometries. The user can set the construction of the spline
through external to the line control points or through internal to the line points, and
specify the value of degree included in the range 1÷100, by default set to value 3 as
interpolating cubic spline.The textual dialogue interface of the Terminal defines the
procedure to generate the geometries. The Terminal accepts to enter the X Y Z coordinates,
i.e.: 100 -100 0, for the construction points after selection and eventually the distance value,
i.e.: 100.5, after the previous point. The Z coordinate is optional, by default it is set to 0.
1. Click Spline from Geometry > Curves menu.
2. Select the construction criteria.
After enabling the command an interactive menu is show on the screen with the
construction criteria. Select the desired methods:
-spline throug control points, to define the geometry built
throug external points to the line;
- spline throug points, to define the geometry built throug
internal points belonging to the line and the value editable of
degree, by default set to value 3 as interpolating cubic
spline;
3. Specify the construction points.
Click in work plane or type coordinate X Y Z or type the distance value to define the
construct point to buid the spline.
4. End.
Press [Enter] on the keyboard or Right-Click to terminate the command.
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Rectangle
Geometry > Curves > Rectangle
1. Click Rectangle from Geometry > Curves menu.
2. Specify the first point, first corner.
Click anywhere in work plane or type coordinate X Y Z to assign the first point of
rectangle.
3. Specify the second point, second corner.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure of segment for the first and second side of rectangle.

Circle
Geometry > Curves > Circle
1. Click Circle from Geometry > Curves menu.
2. Specify the first point, center of the circle.
Click anywhere in work plane or type coordinate X Y Z to assign the first point as center of
the circle.
3 .Specify the second point, radius of the circle.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure of segment to assign the radius of the circle.

Ellipse
Geometry > Curves > Ellipse
1. Click Ellipse from Geometry > Curves menu.

STKO
41

2. Specify the first point, center of the axes of the ellipse.
Click anywhere in work plane or type coordinate X Y Z to assign the first point as center of
the conic section identified by the intersection of the major and minor axis of the ellipse.
3. Specify the second point, first semiaxis of ellipse.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure of segment to define the first semiaxis, major or minor, of ellipse.
4. Specify the second point, second semiaxis of ellipse.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure of segment to define the second semiaxis of ellipse.

Arc of Ellipse
Geometry > Curves > Arc of Ellipse
1. Click Arc of Ellipse from Geometry > Curves menu.
2. Specify the first point, center of the ellipse axes.
Click anywhere in work plane or type coordinate X Y Z to assign the first point as center of
the conic section identified by the intersection of the major and minor axis of the ellipse.
3. Specify the second point, first semiaxis of ellipse.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure of segment to define the first semiaxis, major or minor, of ellipse.
4. Specify the second point, second semiaxis of ellipse.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure of segment to define the second semiaxis of ellipse.
5. Specify the third point, arc of ellipse.
Click on any point belonging to the ellipse or type coordinate X Y Z of third point or
entering the value of counterclockwise angle generated between the first semiaxis (center
and second point) and the segment identified among the center and the third point.
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2.1.6. Geometry – Surfaces

Figure 54. Surface section in the Geometry drop-down menu

Planar
Geometry > Surfaces > Planar
1. Click Planar from Geometry > Surfaces menu.
2. Select geometry.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
3 End.
Press [Enter] on the keyboard or Right-Click to terminate the command. After
confirmation, the closed geometry will be transformed into a surface.
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Loft
Geometry > Surfaces > Loft
1. Click Loft from Geometry > Surfaces menu.
2. Choose the construction parameters.
After enabling the command an interactive menu is show on the
screen for the choice of construction criteria. Select the desired
type of algorithm: Ruled, generates a surface with a linear
profile; Smooth, generates a surface with a curvilinear profile
choosing the methods of the Chord Length, Centripetal,
Isoparametric. The Remove Input parameter eliminates or
preserves the input construction geometries. Reset Default
restore to the starting conditions.
3. Select geometry.
Click on any point belonging to the geometries and Right-Click to enable selection. After
confirmation, the selected geometries will turn red.
4. End.
Press [Enter] on the keyboard or Right-Click to terminate the command. After
confirmation, the closed geometry will be transformed into a surface.

Face 3/4
Geometry > Surfaces > Face 3/4
1. Click Planar from Geometry > Surfaces menu.
2. Specify the first point.
Click anywhere in work plane or type coordinate X Y Z or to assign the first point.
3. Specify the second point.
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Click anywhere in work plane or type coordinate X Y Z or entering the scalar value to
assign the second point to define the first side of the polygon.
4. Specify the third point.
Click anywhere in work plane or type coordinate X Y Z to assign the third point to define
the second side of the polygon.
5. Specify the fourth point.
Click anywhere in work plane or type coordinate X Y Z to assign the fourth point to define
the third side of the polygon. The polygon will be closed automatically and a face will be
generated from the figure.

Surface Modeling Examples
To create a surface from curves, choose the command Geometry > Loft from Toolbar.
Specify Loft Algorithm: Ruled for broken surfaces or Smoothed (with the choice of three
approximations: chordlenght, centripetal, isoparametric). Select Ruled by interactive menu.
Select the first Wire/Vertex and then all next entities (wire, edge or vertex). Enter to finalize
the command.

Figure 55. Start from two polyline as cross-sections.

Figure 56.Loft between the cross-sections.

Figure 57. Then close with a Planar surface.

Figure 58. Example of loft algorithm completed.
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2.1.7. Geometry – Solids

Figure 59. Solid section in the Geometry drop-down menu

Figure 60. Solid Section in the Geometry main Toolbar

Sphere
Geometry > Solids > Sphere
1. Click Sphere from Geometry > Solids menu.
2. Specify the first point, center of the sphere.
Click anywhere in work plane or type coordinate X Y Z to assign the first point to define
the center of the sphere.
3. Specify the second point, radius of the sphere.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value to
define the radius of the sphere. Assigning the second point, the command will end and
generate a sphere in space.
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Parallelepiped
Geometry > Solids > Parallelepiped
1. Click Parallelepiped from Geometry > Solids menu.
2. Specify the first point, first corner.
Click anywhere in work plane or type coordinate X Y Z to assign the first point as first
corner of parallelepiped.
3. Specify the second point, first side.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure to assign the second point, as second corner, to define the first side of the polygon
rectangle.
4. Specify the third point, second side.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure to assign the third point to define the second side of the polygon rectangle.
5. Specify the fourth point, height.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure to assign the fourth point to define the height of the parallelepiped.

Cylinder
Geometry > Solids > Cylinder
1. Click Cylinder from Geometry > Solids menu.
2. Specify the first point, circle center.
Click anywhere in work plane or type coordinate X Y Z to assign the first point as center of
circle to the base of geometry.
3. Specify the second point, cylinder radius and the third point, cylinder height.
Click anywhere in work plane or type coordinate X Y Z or entering the scalar value of
measure to assign the second point to define the radius of circle and the height of cylinder.
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2.1.8. Geometry – Boolean

Figure 61. Boolean section in Geometry drop-down menu

Figure 62. Boolean section in the geometry main Toolbar

Merge
Geometry > Boolean > Merge
1. Click Merge from Geometry > Boolean menu.
After click Merge STKO activates a setting window in
which user has to choose between a full Boolean
operation and just glue the conicidiing subshapes.
2. Select the geometries to merge.
Click on any point belonging to the geometry. After click selection, the geometry turns red.
Right-Click to enable the function.
3. End.
Press [Enter] on the keyboard or Right-Click to terminate the command. After confirmation,
the closed geometry will be transformed into a face.
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Union
Geometry > Boolean > Union
1. Click Union from Geometry > Boolean menu.
2. Select the geometries to union.
Click on any point belonging to the geometry. After click selection, the geometry turns red.
Right-Click to enable the function.
3. End.
Press [Enter] on the keyboard or Right-Click to terminate the command. After confirmation,
the closed geometry will be transformed into a face.

Subtract
Geometry > Boolean > Subtract
1. Click Subtract from Geometry > Boolean menu.
2. Select the first geometry, master.
Click on any point belonging to the starting geometry, defined as master. The command
allows you to select simultaneously multiple geometries. . After, the selected geometries
will turn red. To assign the selected geometry press the [Enter] key or Right-Click to enable
selection.
3. Select the second geometry, slave.
Click on any point belonging to the second geometry, defined as slave. The command
allows you to select simultaneously multiple geometries. . After, the selected geometries
will turn red. Press [Enter] on the keyboard or Right-Click to terminate the command to
assign the selected geometry. After confirmation, the union between the geometries will be
returned.
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Intersection
Geometry > Boolean > Intersection
1. Click Intersection from Geometry > Boolean menu.
2. Select the first geometry, master.
Click on any point belonging to the starting geometry, defined as master. The command
allows you to select simultaneously multiple geometries. . After, the selected geometries
will turn red. To assign the selected geometry press the [Enter] key or Right-Click to enable
selection.
3. Select the second geometry, slave.
Click on any point belonging to the second geometry, defined as slave. The command
allows you to select simultaneously multiple geometries. . After, the selected geometries
will turn red. Press [Enter] on the keyboard or Right-Click to terminate the command to
assign the selected geometry. After confirmation, the union between the geometries will be
returned.
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2.2. Defining and Assigning Local Axes
Local coordinates system is defined such that the local x-axis will correspond to the tangent of
a curve. Both other axes (y-axis and z-axis) will be defined perpendicular to this local x-axis.
For first, this command enables to sections to be aligned to beam-elements (Figure 53). In
STKO Local Axes command translates as Geometric Transformation command of OpenSees
(For more Information, please consult:
http://opensees.berkeley.edu/wiki/index.php?title=Geometric_Transformation_Command&ol
did=2626 ).

z

z
y

x
tangent

y

Figure 63 . Configuration of local axes in a double T section

Secondly, defining and assigning Local Axes is also used to apply loads to the local
coordinates system of a surface like the example below:

Figure 64. Local Axes Assigment

Figure 65. FaceForce Assigment

And finally, STKO allows to export data in Post-Processor and to visualize results according to
global and local axes previously assigned.
Choose the command Property > New from the Toolbar.
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Figure 66. Local Axes toolbar.

2.2.1. Quadratic Local Axes
Quadratic Local Axes for a three-dimensional space is an ordered triplet of axes (ex, ey and ez
vectors) that are pair-wise perpendicular. When local axes are displayed in the STKO window,
ex vector is red, ey vector is green, and ez vector is blue and is always normal to the plane of
the object like in the example below:

Click on Quick Access toolbar to
show/hide local axes

Figure 67. Visualization of local axes

To define a different direction from default Local Axes:
Select Geometry > Local Axes > Quadratic Local Axes or rightclick on Local Axes > Add from the Work Tree. Assign a name to
the new local axes and choose the type to assign.
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Click on OK to confirm the Editor. Specify the first point (origin) or type x, y, z coordinates.
Then, specify the second point (the X-axis) or type x, y, z coordinates. Follow the same steps
for the third point (X-Y plane).
To assign the New Local Axes to a surface, edge or solid, right-click on the new local Axes >
Assign > select the geometry > right-click to confirm.

Figure 68. Visualization of quadratic local axes

Otherwise, click on the New Local axes and drag it on the geometry from the Work Tree. On
the contrary, drag the item and hold CTRL button to unassign the new local axes.
To Edit the quadratic local axes, right-click on the New Local Axes > Edit and the Editor panel
will appear. Now, it is possibile to assign a load to the geometry in order to direct it according
to the new local axes.
2.2.2. Cylindrical Local Axes
Select Geometry > Local Axes > Cylindrical Local Axes or right-click Local Axes > Add from
the Work Tree. Assign a name to the new local axes and choose the type to assign.
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Figure 69. Local axes editor

Click on OK to confirm the Editor. Specify the first point or type x, y, z coordinates. The first
point will be the origin around all the vectors rotate. Then, specify the second point (the Xaxis) or type x, y, z coordinates. Same way for the third point (X-Y plane).

Figure 70. Visualization of cylindrical local axes to the edge of the surface

Figure 71. Visualization of cylindrical local axes to the center of the surface

STKO
54

To assign the New Local Axes to a surface, edge or solid, right-click on the new local Axes >
Assign > select the geometry > right-click to confirm.
Otherwise, click on the New Local axes and drag it on the geometry from the Work Tree. On
the contrary, drag the item and then hold CTRL button to unassign the new local axes.
To Edit the cylindrical local axes, right-click on the New Local Axes > Edit and the Editor panel
will appear.
Now, it is possibile to assign a load to the geometry in order to direct it according to the new
local axes.

2.2.3. Spherical Local Axes
Select Geometry > Local Axes > Spherical Local Axes or right-click Local Axes > Add from
the Work Tree. Assign a name to the new local axes and choose the type to assign.
Click on OK to confirm the Editor. Specify the first point or type x, y, z coordinates. The first
point will be the origin around all the vectors rotate. Then, specify the second point (the Xaxis) or type x, y, z coordinates. Same way for the third point (X-Y plane).
To assign the New Local Axes to a surface, edge or solid, right-click on the new local Axes >
Assign > select the geometry > right-click to confirm.
Otherwise, click on the New Local axes and drag it on the geometry from the Work Tree. On
the contrary, drag the item and then hold CTRL button to unassign the new local axes.

Figure 73.Visualization of spherical local axes

Figure 72.Visualization of spherical local axes
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2.3. Interaction Modeling
Interaction Modeling defines the links between nodes or with elements in order to simulate
the relationship that occurres between elements like beam-column, beam-beam, general
structural constraints ect.

General Beam Links

Figure 74. Example of General Beam Links

Opensees supports three types of Interaction: Node-to-Node links, Node to Element Links,
General Links.
Choose the command Interaction > New from the main Toolbar

or Right-Click on

Interaction > Add from the Work Tree.
A new window (Interaction Editor) will appear to rename, edit and specify the Interaction type:
Select the default Interaction Type: Node-to-Node links. Click on OK to confirm the
Interaction Editor. The output bar will guide the user to first select the Master Element.
Therefore Right-Click to confirm the first choice and to select the Slave Element. After that,

Figure 75. Interaction Editor
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user can see: the new Interaction between nodes as showed below.

Slave Geometries (node3)

Master Geometry (node1)

Figure 76. Example of Node to node links

For Node-to-Node links, we refer to OpenSees website where the example ZeroLength
Element explains this Interaction Type.
For more info visit the webpage:
http://opensees.berkeley.edu/wiki/index.php/ZeroLength_Element
If user wants to work with General Links between elements as - for example, a surface and a
line:
Choose the Interaction command > New from Toolbar or right click on Interaction > Add
from the Work Tree.
A new window (Interaction Editor) will appear to rename, edit and specify the Interaction type
In this case, choose General Link. OK to confirm the settings.
First, select the Master Geometry and then the Slave Geometries. Right-Click to confirm the
choice. Something like the example below will appear:
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Slave Geometry (edge)

Master geometry (line)

Figure 77. Example of General Links

For General Link we refer to OpenSees website where the example ZeroLenghtContactNTS2D
explains this Interaction Type.
For more info visit the webpage:
http://opensees.berkeley.edu/wiki/index.php/ZeroLengthContactNTS2D
If user wants to work with Node to Element links between elements as - for example, a
surface and a line:
Choose the command Geometry-Interaction > New Interaction from Toolbar or right-click
on Interaction > Add from the Work Tree.
A new window (Interaction Editor) will appear to rename, edit and specify the Interaction type.
In this case, choose Node to Element links. OK to confirm the settings.
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First, select the Master Geometry and then the Slave Geometries. Right-click to confirm the
choice. It will appear something like the example below:

Slave Geometry (edge)

Master geometry (line)

Figure 78. Example of Node to element link

Trying to mesh the surface with structured quadratic mesh, this is the result of interaction:

Slave Geometry (edge)

Master Geometry (line)

Figure 79. Example of Node to element link
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For Node to Element links, we refer to OpenSees website where the example
BeamContact3D explains this Interaction Type.
For more info visit the webpage:
http://opensees.berkeley.edu/wiki/index.php/BeamContact3D
Other Example of Interation Modeling

Interaction Type:
Node-to-Node
links

Slave geometries (faces)

Master Geometry
(line)
Figure 80. Example of node-to-node links Interaction

NOTE: EqualDOF, rigidLink and rigidDiaphragm can be only applied to the Interaction.
In this example: choose Interaction
> General link > select the master
node > select the slave nodes > Ok
to confirm. After that will assign the
rigidDiaphragm to the interaction.

NOTE: Interaction will also influence the meshing and partition phase. For more information
about Meshing, please consult § 2.8Meshing . For more information about Partition, please
consult § 2.8.8 Partition
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2.4. Defining and Assigning Physical Properties
To define and assign Physical Properties to the model, choose Property from the Toolbar:

Figure 81. Property section in the main Toolbar

2.4.1. Materials
Choose the command Property > New physical property from the Toolbar, otherwise
directly right-click on Physical properties > Add from the Work Tree Panel.

1
2
3
.
4

Figure 82. Physical Property Editor

Choose a Name to attribute to Opensees Material (1) and customize its aspect through the
command Edit shader (2) to enter the Visual Material Editor:
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Figure 83. Visual Material Editor

Choose Diffuse and Specular color and give Shininess and Trasparency to the new
material. Also, choose Edge and Point color with different width and size. Mesh edge color
and Mesh edge color reduction is customizable too. Click on Ok to confirm Visual Material
Editor.
Click on Model (3) to choose the physical property model and select materials > uniaxial or
nD Opensees materials.
Once selected the “Type”, user can type a Value to Attributes and read the description of
each Attribute with an external link connected to Opensees website.
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(4)

link

Figure 84. Physical Property Editor

To quickly select an Attribute, click on Filter (4) and type the first letter of the attribute to
choose.
Click on Ok to confirm Physical Property Editor and then click on Assign
physical property to attribute the new Material to the geometry:

Figure 85. Window of item selection

Otherwise directly select Physical properties > materials from the Work Tree Panel and
choose the item.
To Edit, Delete or Clone the created material click on Property and select the corresponding

Figure 86. Delete, Clone and Edit physical property
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command from the Toolbar.
Otherwise directly select Physical properties > materials, right click on the item and choose
the command from the Work Tree Panel.

Figure 87. Remove, Clone, Edit and Assign a Material from the Work Tree

Materials and physical properties in general, can be assigned:
-By Right-click on Assign in the main toolbar;
-By Right-click on the item in the work tree and selecting assign from drop-down menu;
-By Drag and drope from the work tree till the desired geometry.
NOTE: Once the material has been assigned to the geometry this will turn in the set material
colour.
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with material

without material

Figure 88. Example of surface with or without material

Suppose some examples of how to set new physical property in STKO.
Choose the command Property > New Physical property from
Toolbar.
As seen before, a Physical Property Editor will appear. Type a name, graphically edit Material
and choose Model. With this command is possible to select different Materials or Sections.
Select, for instance, New Physical Property > Model > materials > uniaxial > Steel and
Reinforcing Steel Materials > Steel04
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Check Box

Right click on the
feature and one
click out the string
to see the feature
below

Description
link
Figure 89. Physical Property Editor

Click on Ok to confirm the Material. It will appear in the Work Tree under the corresponding
item.
Same process if user needs to select a Concrete Material.
Select, for instance, New Physical Property > Model > materials > uniaxial > Concrete
Materials > ConfinedConcrete1. This command is used to construct an uniaxial material
object of confine concrete
For more information, please consult:
http://opensees.berkeley.edu/wiki/index.php/ConfinedConcrete01_Material
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Checkbox
Optional parameters are Boolean
parameters which permits to activate
or disactivate variables

“Autoexclusivo” Optional Features

Figure 90. Physical Property Editor of ConfinedConcrete01

Click OK to confirm the new material. It will appear in the Work Tree under the corresponding
item.Same process if needs to select an Other nD Materials like FaFourSteelPCPlaneStress.
This command is used to construct a Prestressed Concrete Plane Stress material object.
For more information, consult:
http://opensees.berkeley.edu/wiki/index.php/Plane_Stress_Concrete_Materials
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Empty Drop-down
menu. Need to specify a
Material which is
previosly defined

Drop-down menu with
the previosly defined
Material

Material to specify:
ConcreteL01,
ConcreteZ01

Figure 91. Physical Property Editor of
FAFourSteelPCPlaneStress

Figure 92. Physical Property Editor of
FAFourSteelPCPlaneStress

Click on Ok to confirm the new Material. It will appear in the Work Tree under the
corresponding item.
To select, for instance, a Standard Uniaxial Materials:
Materials > Parallel. This command is used to construct a parallel material object made up
of an arbitrary number of previously constructed UniaxialMaterial objects.
For more information, consult:
http://opensees.berkeley.edu/wiki/index.php/Parallel_Material

A new Dialog will appear for specify Attributes, Values of Factors and Materials:
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Type numbers
of vectors

1. Click on -factors

2. Click on the string
and then on the
three-point button

Figure 94. Quantity Vector N Editor

Figure 93. Physical Property Editor of Parallel material

After defining the Quantity Vector, the Physical Property Editor will update the new input:
Same

process

will

be

done

for

Material Tags: Click on three-point
button nearby (Index vector (0)) and
select how many rows will have the
Index Vector. Select the previously
defined Material under each row (i.e.
ConcreteL01):

Figure 95. Index Vector Editor

STKO
69

Click on Ok to confirm the new Material. It will appear in the Work Tree under the
corresponding item.
Once define all Materials, the user can modify the physical property even if it has already
been assigned to geometry.

2.4.2. Cross-Sections
2.4.2.1. Elastic Beam Cross-Sections
To create an Elastic Beam Cross-Section, click on Property > New physical property from the
Toolbar, otherwise directly right-click on Physical properties > Add from the Work Tree
Panel.
Then the physical property Model can be choosen from the new interface. Click on Sections

Figure 96. Physical Property Editor of an Elastic Beam Cross Section

from the drop-drown menu and select, for instance, Elastic as shown below.
An informative table relating to Elastic Section will appear. Click on three-point button
(Undefined) under the Section row. Then a BeamCrossSection Editor will open for selecting
the section type from the Database (1), the section preset with the sizes from Section (2) and
the Unit (3) to assign to the elastic section. All the available sections may be customized by
users in terms of size, otherwise used with the standard available sizes.
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(1)

(2)
(3)

Chart of values

Preview of Section
customized by user

Figure 97. Beam Section Editor

Click OK to confirm the settings. The new section will appear in Physical Properties > Cross
Section > Elastic Beam Cross Sections from the Work Tree. Now it is ready to be assign to
the model.
The new Elastic Section can be modified at all time. Click on Edit Physical property from the
Toolbar and select the item from the list or click on Physical Property > sections > right click
on the item and choose Edit.
2.4.2.2. Fiber Beam Cross-Sections
After defining Materials, to create a Fiber Beam Cross-Section, click on Property > New
physical property from the Toolbar, otherwise directly right click on Physical properties >
Add from the Work Tree Panel.
Then the physical property Model can be choosen from the new interface. Click on sections
from the drop-drown menu and select, for instance, Fiber as shown below.
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Figure 98. Physical Property editor of a Fiber

An informative table relating to Fiber Section will appear. Click on three-point button under
the Fiber section row. Like in STKO pre and post interface, a Terminal (3) contains two text
editors: the first is what the software is generating after an user’s input, the second is the
Input bar in which elements like, for example, coordinates of points can be written.
(1) Name Bar

(2) Quick Access
Toolbar

Render Window
(3) Terminal

Figure 99. Mpc Beam Fiber Section Editor

Example: user has to assign three different types of Materials: concrete cover, concrete
core, rebars and, for instance, a Fiber Reinforced Polymers (FRP).
Select the Rectangle command from the Quick Access Toolbar to draw a Beam Section that
will be the concrete cover (outer rectangle).
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The Terminal bar specifies ways to design rectangle: manually (specify the first and second
corner) or type x y and z (optional) coordinates, i.e.: 10 10 0, after the first corner.
User can also specify rectangular width and height after the first corner.
A second inner rectangle will be drawn in order to apply the second material: the concrete
core.

Outer rectangle

Inner rectangle

Figure 100. Inner and outer rectangle of a Beam Section

Create an outer and inner surface to make the Material Assignment successful.
Select Face from planar curves command from the Quick Access Toolbar to create
surfaces.
Select the outer wire and then the inner wire > right click of the mouse to confirm the outer
surface. The same will be for the inner surface just selecting the inner rectangle.
After creating two surfaces, click on Make Surface Fiber from the Quick Access Toolbar and
select the outer surface to create a surface fiber. Automatically will appear a Dialog in
which user can rename the surface fibers, insert a Mesh Size and assign a Material (in
our case, concrete cover for the outer surface and concrete core for the inner surface).
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Outer surface
Inner Surface

Figure 101. Inner and outer surfaces

Figure 102. Assigment of Mesh Size and Material

Figure 103. Fiber Beam Cross Section

To add rebar Material, draw another inner rectangle and select the Make Punctual
Fibers command. Automatically a Dialog in which rename the Rebars will show up.
Insert Rebar data where specify the diameter, the number of rebars on each segment or the
spacing of rebars. Assign the Material and click on Ok to confirm.
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Rebars
s

Figure 105. Detail of Rebars
Figure 104. Dialog of the Rebar Material

To create a FRP Material, draw a line to simulate it and select the Linear Fibers
command from the Quick Access Toolbar.

Figure 106. Dialog to size mesh, thickness and material

Figure 107. Detail of the linear fiber mesh

Click Ok to confirm the Section Fiber and confirm the Physical Property Editor.
The new section will appear in Physical Properties > sections and select the item from the
Work Tree. Now it is ready to be assign to the model.
To remove, clone, edit and assign the Fiber Section click on Edit Physical property from the
Toolbar and select the item from the list or click on Physical Property > sections > right click
on the item and choose the command.
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2.4.3. Special Purpose for Physical Properties
In STKO is not allowed to assign more physical properties to an element because a property
assignment overwrites the previous one. It is generally a valid assumption for finite element
field. For this reason, STKO enables user to create a Special Purpose that is a “container” in
which more physical properties coexist. After creating more physical properties or element
properties such as sections, materials ect. It is possible to create a special purpose like a
BeamSection property in which insert previously-defined sections. Furthermore, user can
create different Special Purposes to attribute to different geometries (e.g. beams and
columns).
After creating sections (for example IPE100 and IPE120) it is now possible to create two
Special Purposes from Property > New physical property from the Toolbar, otherwise
directly right click on Physical properties > special_purpose > Add from the Work Tree
Panel.
Select, for instance, Beam-Column > BeamSectionProperty. An informative table relating to
BeamSection Property will appear. Insert the previously created section type.

Figure 108.Special Purpose for Physical Properties (IPE100 and IPE120 of BeamSectionProperty)
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Special
Purpose 2

Special Purpose 1

Figure 109. Visualization of Special Purpose

Click on OK to confirm the settings.
A particular example is the HingedBeam Special Purpose to create a “special purpose into a
special purpose”. Create uniaxial materials such as Steel and Reinforcing-Steel Materials
(Steel01). After that, create zeroLength special purposes to insert into the HingedBeam:
Select New Physical Property > special_purpose > zero-Length Material >
zeroLengthMaterial from the Toolbar or right click on special_purpose > Add from the Work
Tree.

Previously-defined
uniaxialMaterials

Figure 110. Physical Property Editor of a zeroLengthMaterial

After creating zeroLengthMaterials, create a new special purpose HingedBeam:
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Beam
Physical
property
Insert
previouslydefined
zeroLength

Click on Ok to confirm the settings. Select the element and assign the new Special Purpose:

HingedBeam

Figure 111. Visualization of HingedBeam
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OpenSees

Figure 112.Scheme of the element relationship that occurred between OpenSees and STKO

OpenSees

Figure 113. Schemeof the element relationship that occurred between OpenSees and STKO

NOTE: After creating a Special Purpose for Physical Properties, STKO allows to generate
Regions before launching the Analysis (see § 2.9.1.2.1 Regions).

2.5. Defining and Assigning Element Property
Choose the command Property > New element Property from the Toolbar,
otherwise directly right click on Element properties > Add from the Work Tree Panel.
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Figure 114. Element Property Editor

A new interface with the same Physical Property layout will appear, as shown above. Select
the finite element that will define the geometry and assign values to the table.

Description of the attribute and link
to Opensees website

Figure 115. Element Property Editor of an elasticBeamColumn

Click OK to confirm the settings. The new element will appear in Element Properties ->
beam_column_element (in this case) from the Work Tree. After defining a physical property
like materials, sections and special_purpose, it is ready to be assigned to the model.
It is possible to modify the new element at all time. Click on Edit Element property from the
Toolbar and select the item from the list or click on Element Properties >
beam_column_element > right click on the item and choose Edit.
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NOTE: Do not forget to mesh the geometry to definitively assign Element properties. Click on
Mesh > Build mesh from the Toolbar.

Example: Draw a Frame Structure, define and assign physical properties and finite elements.

Figure 116. Example of a Frame Structure

Choose the command Property > New physical property from the Toolbar, otherwise
directly right-click on Physical properties > Add from the Work Tree Panel. Select, for
example, an uniaxial material and edit shader for define the aspect of geometry:
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Figure 117. Example of creation of Unaxial Material

Assign the new Physical property to geometries with the aid of selection boxes in the QuickAccess menu:

To only select:

nodes | edges | surfaces | solids| all| interaction

Once geometries have the new physical property, it will notice a difference in colors:
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Figure 118. Example of assignment of uniaxial material to the columns

Same thing for another New Physical Property:

Figure 119. Example of assignment of uniaxial material to the beams

Now add a New element property to assign to geometries. Choose one of available finite
element and confirm it.
Then click on Assign element property to attribute the new element to the geometry,
otherwise directly select Element properties > right click on the element > Assign.
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The model is ready to be meshed and exported. Select Mesh > Global seed > Choose the
“Type” and “Division” and then select Build Mesh

Figure 120. Mesh of the frame structure

It is also possible to assign a Condition model, as follows in § Defining and Assigning
Boundary Conditions and Loads.
2.5.1. Special Purpose for Element Properties
Like the Special Purpose for the Physical Properties, STKO also allows to create a Special
Purpose for Element Properties (HingedBeamColumn). It automatically applies the
zeroLength to the element that will generate extra nodes:

Figure 121. Scheme of a beam

Figure 122. Scheme of a beam with extra nodes

To create Element Property, click on Property > New element property from the Toolbar,
otherwise directly right-click on Element Property > Add from the Work Tree Panel.
Then choose the element property Model from the new interface (i.e. a zerolength element)
and repeat the process for other elements:
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Figure 123. New element property - zeroLength

After creating n elements it is now possible to create a Special Purpose from Property > New
element property from the Toolbar, otherwise directly right click on Element properties >
special_purpose > Add from the Work Tree Panel.

Figure 124. New element property - special_purpose
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Insert the Beam or Column
Element
Insert zeroLength
previously created

Figure 125. New element property - HingedBeamColumn

After inserting zeroLength_i and zeroLength_j, click on OK to confirm the settings. Assign the
new Special Purpose to the Beam or Column.
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2.6. Defining and Assigning New Definition
Choose the command Property > New Definition from the Toolbar, otherwise
directly right click on Definition > Add from the Work Tree.
A new interface with the same Physical Property
and Element Property layout will appear, as
shown
different

above.

User

can

frictionModel

choose
like

between
Coulomb,

VelDepMultiLinear ex. In this section user can
also attribute timeSeries and choose between
Linear, constant, Path (as shown in the example
below). Definitions are general objects that are
not assigned to the geometries or to the
Figure 126. Definition Editor

interactions. For this reason, the Definitions do
not allow the command “Assign”.

Choose frictionModel or timeSeries and assign values to the table like in this example
(Multi-Linear Velocity Dependent Friction) from the frictionModel:

Link to OpenSees Website
Figure 127.Definition editor Path TimeSeries

Figure 128. Definition Editor of VelDepMultiLinear

Every group that belongs to each definition model contains a link to OpenSees website
(http://opensees.berkeley.edu/wiki/index.php/Main_Page). It is the description of each item.
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2.7. Defining and Assigning Boundary Conditions and Loads
From Preprocessing interface, choose the command Condition > New Condition
from the Toolbar. Here user can add a new Boundary Condition to assign to geometry.

1
2
3

Choose a Name to attribute to the Boundary Condition (1) and customize its aspect through
the command Edit shader (2) to enter the Visual Material Editor:

Choose Diffuse and Specular color and give Shininess and Trasparency to the condition.
Also, choose Edge and Point color with different width and size. Mesh edge color and Mesh
edge color reduction is customizable too.
Click on Ok to confirm Visual Material Editor.
Click on Model (3) to select Constraints, Ground_Motion, Loads or Mass.
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To assign Constraints to the model:
Choose the command Condition > New Condition from Toolbar.
Select Constraints from the drop-down model menu and
choose between mp and sp constraint.
Therefore, selecting for instance, sp Constraints > fix an
editing window will appear.
In this section user can set the degree of freedom to
assign to an element and in which direction it acts.
NOTE: Unlike the physical properties conditions must be
attributed to the element by selecting it while the editing
window is still open. The selected geometries will turn
red, this means that STKO is attributing the condition
those items.
In case of condition editing after assignment to edit the
assignment reselect the entities and the modified
condition will act on. For instance in case of target
Figure 129. Constraints window editor.

changement user has to re-assign the condition to each
element.

Figure 130. Example of attribution of constraints

STKO
89

To select Loads to the model:
In case of loads, after selecting loads from the dropdown menu user has to choose between:


force > edgeCouple, nodeforce, faceForce
ecc.



eleLoad > eleLoad_beamuniform(see figure
below)



sp > prescribed nodal values

Once defined the kind of load user can specify the
mode of application and the quantity of force in
every direction (in 2D and 3D).
Like constraints the loads must be attributed to the
element by selecting it while the editing window is
still open.

eleLoad_beam
uniform

Figure 131.Visualization of model load attribution

For example to assign loads in the model:
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Choose the command Condition > New Condition from Toolbar.
Type a Name to attribute to the Boundary Condition and customize its aspect through the
command Edit shader to enter the Visual Material Editor. Click on Model and Select >
Loads > Force > NodeForce:
Edit it an assign it to an element.

Positive Force

Negative Force

Figure 132. Visualization of positive and negative Nodal Force

To Edit, Delete or Clone the new condition click on Condition and select the corresponding

Figure 133. New, Delete, Clone, Edit condition from Condition section of the main Toolbar

command from the Toolbar.
Otherwise directly select Condition > Loads > right-click on the item and choose the
command from the Work Tree Panel.
In addition to FaceForce load, Opensees provides other types of load like:
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In

spite

of

different

available

applications,

Opensees only processes nodal forces. For this
reason, STKO displays these Forces on nodes by
means of lumping.

The Lumping is the transposition of a uniform distributed load in nodal loads. To better
understand this “transposition”, see the following example:

Stressed area
of nodes
Figure 134. Uniform distributed load over a meshed surface

Figure 135. Example of Lumping

Before we saw a ForceForce example on a 3D solid, with constant mode, a local axis
orientation and a 3D force vector.
User can also choose a function mode of every Force type from the Condition Editor:
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Figure 136. Example of EdgeForce with function mode over a Beam

Figure 137. Example of FaceForce with function mode over a Surface
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Figure 138. Example of VolumeForce with function mode over a Solid 3D

2.7.1. BeamSolidCoupling
BeamSolidCoupling is a constraint element that unifies a solid element (ndm= 3; ndf= 6) with a
beam element (ndm= 3; ndf= 3) through Interactions (§2.5 Interaction Modeling). These
interactions will create two mp constraints: EqualDOF and a RigidLink. The equalDOF links
the solid nodes to an “extra nodes” and the RigidLink connects the “extra nodes” to the beam
node. The beam node is the master node of the Rigidlink and its slave nodes are the “extra
nodes”. Also, “extra nodes” are master nodes of the equalDOF and its slave nodes are the
solid nodes. To better understand the beamSolidCoupling command, see the sketch below:

Interactions between a solid and a
beam element

Fictitious identification of master
nodes and slave nodes in the
RigidLink and EqualDOF

2.7.2. ForcefromReaction
STKO enables user to set more Analysis steps. Once concluded the first Analysis, it is possible
to read all resultant forces on nodes and apply them like Force. It means that a reaction may
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be converted in Force (ForcefromReaction command). The following example shows two
Analysis steps:

EdgeForce
(right edge)

Fix
constraint
(left edge)

Fix constraint
(base)
Figure 139. First Analysis Step

(1)
(2)
(3)
(4)
(5)
(6)
(7)
(8)

Analysis Step 1:
After defining Constant timeSeries (1) from
Definitions. Attribute Physical properties (2)
(material elastic_isotropic, plate_fiber ecc.) and
Element properties (3) (ShellMITC4). Then
assign constraints to the shell: fix constraint
(4) to the base and fix constraint to the left
edge of the shell. In addition, assign an
EdgeForce (5) to the right.
Therefore define a Recorder (6) checking all the
nodal results to display after. Before creating a
new Analysis step, do not forget to set Patterns
(7), two for constraints and one for load. Setting
the first sp constraint (fix constraint on the
base) in the first constraintPattern and the
second sp constraint (fix constraint on the left
edge) in the second constraintPattern. Then
creating a third Pattern for the load and
inserting the edgeForce in load and the
timeSeries previously defined in tsTag. Finally
setting the first Static Analysis Step (8)
specifying the number of analysis steps to
perform (in this case numIncr= 1).
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(9)

(10)
(11)

Analysis Step 2:
Now defining a new fix constraint to apply to the
right edge of the shell instead of the the force.
Then creating a new Force: ForcefromReaction
(9).
Choose the command New condition from the
main
Toolbar
>
Model
>
Load
>
ForcefromReaction and set the Dimension (2D
or 3D). Assign the Force to the left edge of the
shell.
Necessarily using the removePattern (10) to
remove Load Pattern and spContraint Pattern
(only the fix constraint of the left edge)
previously created. Once removing previously
Patterns, creating new Patterns: one for the
ForcefromReaction (LoadPattern) and one for
the fix constraint (spConstraint Pattern).
Applying the LoadPattern to the left edge and
the spConstraint Pattern to the right edge,
keeping the fix constraint to the base.
Finally setting the second Static Analysis step
(11), specifying the number of analysis steps to
perform (numIncr ≠0 − in this case numIncr=
1−).

Fix constraint
(right edge)

ForcefromReaction
(left edge)
Fix constraint
(base)

Figure 140. Second Analysis Step
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Launching the Analysis in Opensees so that STKO will generate a file .mpco to import in STKO
Post-Processor. Moving to STKO Post Processor interface and open the new Database (.spd):

Moving from MODEL STAGE 1 and MODEL STAGE 2 is possible to see the corresponding
results.
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2.7.3. DistributedLK
Choose the new condition command > Constraints > mp > edgeDistributedLK or
faceDistributedLK from the main Toolbar.
It enables user to insert two materials (Axial material (default), and a Tangential material). This
command respectively generates: “extra” nodes and uniaxial material (Viscosous) applied to
the ZeroLength:
1. “Extra” nodes:

ndm = ndf
Figure 141. Fix constraint

ndm ≠ ndf
Figure 142. equalDOF+fix

2. Uniaxial material (Viscosous) applied to the ZeroLength:
The following example explains the application of the edgeDistributedLK command to an
element.
After defining physical properties (ElasticIsotropic material) and element properties
(SSPbrick element and VS3D4 element) to assign to the geometry, choose the conditions to
apply. Select Condition > New condition > Model > Constraint > mp > DistributedLK2D
from the main Toolbar:
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Figure 143. Condition editor of a DistributedLK2D

Material x

Material y

Figure 144. Assignment of axial material and tangential material

Select the edge and assign the mp constraint. Click on OK to confirm the settings.
After that, add a new load. Condition > New condition > Model > Loads > Force >
FaceForce. Set parameters and assign it to the element. Now create the Timeseries from
Definitions (for example a Trig Timeseries) setting the period, the starting time and the
ending time.
Finally define a Recorder checking the nodal results that want to display after. Before creating
a new Analysis step, do not forget to set Patterns, one for the constraint and one for the load.
Set the first mp constraint (fot the edgeDistributedLK) in the first constraintPattern and then
the loadPattern in which inserting the Timeseries and the FaceForce previously defined.
After that, it is possible to set the Analysis Step specifying the analysis Type (for example
Transient) and all the parameters.
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2.8. Meshing the Geometrical Model
Meshing a Geometrical Model is the most fundamental step in the 3D development process.
STKO supports many “Mesh Modeling” techniques, from the structured curve, surface and
solid mesh to the unstructured one. In this module, the user will learn the parts of a mesh
and how to build 2D and 3D mesh models through Global and Local Mesh Controls.

Figure 145. Some example of meshed solids

2.8.1. Element Type
STKO uses a hybrid mesh generation approach that allows for complex 2D and 3D geometries
to be optimally meshed by using different mesh elements. STKO supports 5 different Element
Types: Linear Type (2 or 3 nodes), Triangle Type (3 or 6 nodes), Quadrilateral Type (4, 8 or 9
nodes), Tetrahedra Type (4 or 10 nodes) and Hexahedra Type (8, 20 or 27 nodes –Serendipity).
Linear Type (2 or 3 nodes) is composed of two nodes at each extremity of the line (Figure
126). The quadratic form (Figure 127) has an additional node in the middle of the line.
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Figure 146. Linear Type with 2 nodes

Figure 147. Linear Type with 3 nodes

Corner Nodes: N1, N2

Mid Node: N3

Triangle Type is composed of 3 nodes located at the three geometric corners of the triangle
(Figure 128). Triangle Type (6 nodes on Figure 129) has three additional nodes located at the
middles of the three edges.

Figure 148. Triangle Type with 3 nodes

Figure 149. Triangle Type with 6 nodes

Corner Nodes: N1, N2, N3

Mid Nodes: N4, N5, N6

Quadrilateral Type is composed of 4 nodes located at the four geometric corners of the
quadrangle (Figure 130). In addition, the Quadrilateral Type with 8 and 9 nodes respectively
has four mid-edge nodes (Figure 131), and a mid-face node (Figure 132).

Figure 150. Quadrilateral Type with
4 nodes

Figure 151. Quadrilateral Type with
8 nodes

Figure 152. Quadrilateral Type with
9 nodes

Edge Nodes: N1, N2, N3, N4

Mid Nodes: N5, N6, N7, N8

Mid-Face Node: N9

Tetrahedral Type is composed of four nodes located at the four geometric corners of the
tetrahedron (Figure 133). Tetrahedral Type also has six additional nodes at the middle of each
of the six edges (Figure 134).
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Figure 153. Tetrahedral Type with 4 nodes

Figure 154. Tetrahedral Type with 10 nodes

Corner Nodes: N1, N2, N3, N4

Mid Nodes: N5, N6, N7, N8, N9, N10

Hexahedral Type (Serendipity) is composed of eight nodes located at the eight geometric
corners of the hexahedron (Figure 135). In addition, Hexahedral Type with 20 nodes has a
node at the middle of each of twelve edges (Figure 136). Hexahedral Type with 27 nodes adds
a node at the middle of each of the six faces, and one at the cell center (Figure 137).

Figure 155. Hexahedral Type with 8 nodes

Corner Nodes: N1, N2, N3, N4,
N5, N6, N7, N8

Figure 156. Hexahedral Type with 20
nodes

Figure 157. Hexahedral Type with 27
nodes

Mid Nodes: N9, N10, N11, N12,
N13, N14, N15, N16, N17, N18,
N19, N20

Mid-face nodes: N21, N22, N23,
N24, N25, N26, N27

2.8.2. Global and Local Mesh Controls
User can get more control over the mesh by using mesh control tools: Global and Local Mesh
Controls. They are available to the Mesh section from the Toolbar.

Figure 158. Global and Local Mesh Control in Mesh section of the main toolbar

First, Import Geometry from the Toolbar and move to Mesh command.
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Figure 159. The work Tree shows all solids of the model.

Before defining the mesh controls, connect all solids through the Merge command. So click in
Geometry > Boolean > Merge and select all geometries to join. A folder of the [n] merged
geometries will appear in the Work Tree.

Figure 160. The work tree
shows all the merged solids of
the model

Figure 161.Visualization after merging

Global Seed, Edge Seed and Remove Seed from Mesh section work to set
dimensions of finite elements. Global Seed command enables user to make global
adjustment in the meshing phase and it includes a uniform, biased and dual
biased distribution by size and divisions.
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Figure 162. Example of Global seed with uniform type by divisions

Figure 163. Example of Global seed with biased type by size

Figure 164. Example of Global seed with dual biased type by size
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To confirm the Global Seed command, click on Done. After that, select Mesh Controls to
define the element of selection (Edges, Faces and Solids), the Algorithm (Unstructured or
Structured), the Topology (Tri/Tetra and Quad/Hexa for Faces/Volume) and the Order of the
Mesh (Linear, Quadratic and Quadratic/Serenditipy). Color Mode will confirm the user’s choice
with different colors for each mesh control.

Figure 165. Set mesh control window

Click on Assign to preview and Done to confirm Mesh Controls.
After defining Global seed and the Mesh Controls, select Build mesh command.
The geometrical 3D model will automatically mesh according to the user’s input.

Figure 166. Example of model while meshing
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Figure 167.Example of model after meshing

To change the Global edge seed with a bigger or lower size, click on Global seed, set the new
size and click on Build Mesh.

Figure 168.Example of global edge setting.

Figure 169. Example of global edge setting.
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Figure 170. Model with wide edge seeds

Figure 171. Model with tight edge seeds

NOTE: To make a Structured Mesh, be careful that the imported 3D model is only composed
by solid geometries like cubes (or geometry with six faces) and four edges in the case of
surfaces. If not, the imported model will be meshed by Unstructured Mesh.
STRUCTURED MESH LAYOUT
SURFACE with four edges

Figure 172. Hierarchical Order of Structured Mesh with quadrilateral grid
SOLID with six faces

Figure 173. Hierarchical Order of Structured Mesh with triangular grid.

STKO TIPS
As mentioned above, in Structured Mesh user can create a triangular or quadratic mesh but
there are some restrictions on the "seed" that the user defines. STKO automatically generates
a warning to inform the user that the number of nodes of a surface edge has been altered
without varying the logarithm (the type of Seed attributed to it: uniform by size, uniform by
division, biased by size etc.) in order to successfully obtain a structured mesh:
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Edge Seed > Uniform by size = 10

Edge Seed >

Edge Seed >

Uniform by size = 5

Edge Seed > Biased by size = 10
Bias= 0.3

Biased by size = 10
Bias= 0.5

Figure 174. Example with different edge seed types

NO CHANGE OF SEED TYPE BUT OF NUMBER OF NODES !

Figure 175. Changing of number of mesh in order to have a "structured" mesh compatibility

STKO
108

Figure 176. Example of Unstructural Mesh

STKO TIPS
In Unstructured Mesh STKO generates a warning if the user sets up a hexagon unstructured
mesh. Therefore, it will convert the user input into a tetrahedric mesh to successfully obtain
the unstructured mesh.

CHANGE OF TOPOLOGY FROM HEXAHEDRA TO TETRAEDRA !

Figure 177. Changing of hexahedra mesh algorithm in tetraedra
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2.8.3. Curve Meshing
After creating curve shapes in STKO, user can set the Edge Seed though the
command from the Toolbar.
User can choose the type of Edge seed to attribute to the curve:
Select the edge > Assign > Done if the Type Divisions is right for the edge.
Click on Mesh Control from the Toolbar to set the Selection in Edges. Select the curve >
Assign > Done and/or directly click on Build Mesh.

Figure 178. Example of a curve meshing

2.8.4. Unstructured Surface Meshing
Parameterization of unstructured surface meshing is of fundamental importance in STKO
especially for complex surface geometries. Triangular and quadrilateral pattern in linear and
quadratic forms have been used to define surface geometry.

Figure 179. Quad Unstructured Mesh of a Surface

Figure 180. Tria Unstructured Mesh of a Surface
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2.8.5. Structured Surface Meshing
STKO can generate a structured quadrilater and triangular surface mesh for any 4-sided
surface. In addition, the mesh spacing can be easily specified or automatically computed by
Mesh Control command:

Figure 182. Tria Structural Mesh of a Surface

Figure 181. Quad Structural Mesh of a Surface

2.8.6. Unstructured Solid Meshing
Unstructured meshes have an irregular topology, meaning that it does not follow a uniform
pattern and user has really to store the topology for each single node (or edges, faces, solids).
This specific feature enables users to reproduce complex geometries and makes unstructured
mesh more flexible.

Figure 183. Example of an unstructured solid meshing

STKO
111

2.8.7. Structured Solid Meshing
On the other hand, a mesh is said to be structured if its topology is regular, i.e. has a wellknown pattern (such as cubes with regular spacing dx, dy, dz between nodes) thus it is easy to
proceed to a "rational" numbering of the nodes. These "meshes" are usually simple
geometries.

Figure 184. Quad/Hex Structural Mesh of a solid

Figure 185. Tria/Tetra Structural Mesh of a solid.

2.8.8. Partition
For parallel computations, STKO provides facilities to partition the mesh. Click on
Mesh from the Toolbar and select the Partition command.
A Partition Mesh window in order to set the Number of partitions will appear:

Preview

Confirm

Figure 186. Partition mesh window to define number of partitions
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Select Partition to preview the model whose visualization will change according to the
number of partitions.

A list of partitions appears like a summary of nodes and elements per partition. Click on Done
to confirm the Partition Mesh.
Even if the visualization will not appear colourful, the Partition has been successful. Partition
mesh window confirms it: click on the Partition command for the second time and will find the
same inputed number of partitions.
To delete the previously inputed number of partitions, press on CTRL+Z (apple+Z for Mac)
from the keyboard.
To change the previously inputed number of partitions, click on Partition and just change the
number of Partitions > Done to confirm.
NOTE: every Partition will create a Processor and a File:

ID 3

ID 2

Launching the Analysis in Opensees, it will
create .tcl files with different processors
and ID like the number of partition
previously defined:

ID 1

ID 0

Figure 187. Visualization of the Partition with three processors (0,
1, 2)
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Figure 188. Process 0 with all relative nodes

Figure 189. Process 1 with all relative nodes

Figure 190. Process 2 with all relative nodes

This command enables user to optimize and automate Analysis times.
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2.9. Analysis
2.9.1. Defining Analysis Steps
2.9.1.1. Patterns
In order to launch the Analysis, it is important to define Patterns and Recorders before.

Figure 191. Analysis steps in the main menu

Figure 192. Analysis steps in the work tree

To define Patterns, right-click on Analysis steps > Add from the Work Tree panel, or
Analysis > New from the main Toolbar.

Choose the AnalysisStep Editor from Model > Patterns > AddPattern and select, for instance,
loadPattern:

MultiSupport, UniformExcitation,
patternConstraints, patternPlain
This command is used to remove
a load pattern or SpConstraints
Figure 193. Add or Remove Pattern from AnalysisStep editor
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The loadpattern is complementary to the
previous settings:
tsTag = insert Time Series;
load = insert force;
eleLoad = insert eleLoad;
sp = insert displacement on single point

Figure 194. loadPattern in the AnalysisStep Editor

Another important pattern type is the constraintPattern. After defining contraints, STKO
allows to create Pattern which contains command to generate sp contraints and mp
constraints as follows:
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Figure 195. Creation of constraintPattern
Figure 196. constraintPattern with sp and mp constraints

Select OK to confirm the settings.
2.9.1.2.

Misc_commands

Misc_commands is a step of analysis that includes several commands. One of them is the
Region.
2.9.1.2.1.

Region

The Region is used to label a group of nodes and elements. This command is also used to
assign rayleigh damping parameters to the nodes and elements in this region. The region is
specified by either elements or nodes, not both. If elements are defined, the region includes
these elements and the all connected nodes.
To create a Region right click on Analysis Steps > Add> Model >Misc_commands from the
Work Tree Panel, or Analysis > New from the main Toolbar:
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1
2

Insert previouslycreated Geometry Set

Figure 197. Creation of region from AnalysisStep editor
Figure 198. Region with previously created Selection Set

1. Selection Set: To create a Selection Set, simply choose Selection sets from the Work Tree
Panel > Add and select the geometry or groups of geometries to add.
2. include_auto_generated_elements:
selection

selection+include_auto_generated_ele

include_auto_generated_eleme

ments

nts − selection

Click on OK to confirm the settings. The creation of Region is not a mandatory step of
Analysis. It is at the discretion of the user.
2.9.1.3. Custom Commands
CustomCommands is another important command that belongs to Misc_Commands. It
enables user to create costum scripts in case of missing commands or simply to customize
some STKO features. To create a customCommands right click on Misc_commands > Add
under the item Analysis steps from the Work Tree Panel, as follows:
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Insert your scriptTCL

Figure 199. Customable scriptTLC interface from the customCommand

It is important to remember that the location where user creates an analysis step is that one
where user is recording each steps. Follow this example to better understand this “concept”:

1

Figure 200. Analysis_Steps.tcl

The second step is the creation of a Pattern with previously-created constraints:
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FIX

2
equalDOF

Figure 201. Creation of fix contraint and equalDOF from the
constaintPattern

Then it is possible to set the First Analysis (Static):

3
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3

3

Figure 202. Creation of the Static Analysis

After that, user can add a second scriptTCL and create another Analysis (VariableTransient)
following the previous steps.
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Figure 203. Creation of a VariableTransient Analysis

2.9.2. Recorders
Now, select Analysis steps > right-click to Add > Model > select Recorders > MPCORecorder
from the drop-down menus. A list of nodal results and element results will appear in the
Analysis Step Editor:

STKO
122

Click on the three-point button to
specify the path and the name of
MPCORecorder (*)

Check the box to select
the nodal results and
element results to write in
the Recorder

Figure 204. Creation of a MPCORecorder from the
AnalysisStep Editor
Customer can type element
results that are not listed
above. (**)

NOTE (*): It’s strictly important to name the MPCORecorder, otherwise it won't be recognized
by STKO in writing moment, so anything won't be recorded.
NOTE (**): Users have to specify if they are nodal results (-N) or element results (-E).
Click on OK to confirm the settings. After that, user can define the last step: the Analyses.
2.9.3. Analysis
STKO proposes three valid Analysis types:
1. Static – for static analysis
2. Transient – for dynamic analysis with constant time step
- Variable Transient – for transient analysis with variable time step.
Choose Analysis steps > right-click on Analyses > Add. An Analysis Step Editor will appear:
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Figure 205. Creation of Analysis Command from the
Analysis Step Editor

When Analysis types change, the selectable parameters will vary:

Node
control

Figure 207.Example of Static Analysis with Displacement
control

Figure 208. Integrator window

Insert number of
analysis steps ≠ 0
Figure 206. Example of Static Analysis Type

STKO let user to control the analysis according to a precise element or group of elements
which can be collected in a Selection Set (see § 2.1.3 geometry set) and picked by a dropdrown menu in the Integrator part of the analysis.
Unlike Opensees, Variable Transient is not a third analysis object but shall be subject to the
Transient Analysis Type:

STKO
124

Insert number of
analysis steps ≠ 0

Insert number of
analysis steps ≠ 0

Figure 209.Example of Transient Analysis
Figure 210. Example of Variable Transient Analysis

Like in Opensees, the analysis-definition part allows the user to define the different linear and
nonlinear available analysis tools. For each analysis, the following items need to be defined,
more effectively in this order:
-

Analysis Type Command
(http://opensees.berkeley.edu/wiki/index.php/Analysis_Command );
Contraints Command
(http://opensees.berkeley.edu/wiki/index.php/Constraints_Command );
Numberer Command
(http://opensees.berkeley.edu/wiki/index.php/Numberer_Command );
System Command
(http://opensees.berkeley.edu/wiki/index.php/System_Command );
Algorithm Command
(http://opensees.berkeley.edu/wiki/index.php/Algorithm_Command );
Test Command (http://opensees.berkeley.edu/wiki/index.php/Test_Command );
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-

Integrator Command
(http://opensees.berkeley.edu/wiki/index.php/Integrator_Command );
Analyze Command
(http://opensees.berkeley.edu/wiki/index.php/Analyze_Command ).

STKO enables user to easily understand each items and subitems thanks to Opensees links
that explain what they are.
In addition, Opensees uses Eigen Command for perform the analysis and generate eigen
values (http://opensees.berkeley.edu/wiki/index.php/Eigen_Command ).
Select Analysis steps > right click on Analyses > Add. The Analysis Step Editor will appear.
Click on Model > Analyses > Eigen:

Figure 211. Creation of eigen from the AnalysisStep Editor

After setting the Analysis, select OK to confirm it. The new Analysis will appear from the
Work Tree.
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NOTE: Remember to respect the order of the Analysis steps. If not, the scroll arrows
enables user to move items in the correct order to successfully launch the Analysis.

2.9.4. Solver
2.9.4.1. Kits
Once defined the analysis steps, user can start the solving part of the analysis.

Figure 212. Solver part in the main menu.

Figure 213.Solver part in the toolbar.

User can select Kits from the main Toolbar. A Solver setting window will appear. In this
window user can Find or Import a solver . Clicking on Find solver STKO automatically
identifies the available solvers and lists them in the auto-detected area. The Auto-detected
solver may be: Opensees, Opensees Mp and Opensees Sp.
Since the moment Opensees is an open source progam user can also costumize it on its own.
STKO gives the possibility to user to use the Opensees Costumized version by clicking on
Import solver and the selected version will be listed in the manual area of the window.
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Figure 214.Solver setting window

2.9.4.2. Write Input File
After defining solver, user Write an Input file. By clicking on Write Input File on the toolbar
STKO will generate 7files in ticle (.tcl) to be solved.

The generated ticle (.tcl) files are non other that the description of the model in order to be
solved by Opensees. They are shered indeed in: main.tcl; definitions.tcl; materials.tcl;
sections.tcl; nodes.tcl; elements.tcl.
1. main.tcl: it is the first model that contains all .tcl files.
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Figure 215. Script of main.tlc

2. definitions.tcl: it describes Timeseries and friction model with all the parameters
previously defined. In this case there are three timeSeries: a constant, a linear and a
path timeSeries in which user can insert coordinates:

Figure 216. Script of all timeSeries values

Figure 217. Script of timeSeries Path

3. materials.tcl: it contains materials which were previously set (an uniaxialMaterial):

Figure 218. Script of material.tcl previously defined

4. sections.tcl: it shows all sections used in the model (in this case Elastic section):

Figure 219. Script of section.tcl
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5. nodes.tcl: it contains only the geometric nodes of the model. It does not show “extra
nodes” of STKO. Together with geometric nodes, nodes.tcl can also contains –mass,
like in the following example:

Figure 220. Script of node.tcl with previously defined nodes and mass

6. elements.tcl: it includes all element properties, including extra nodes for ZeroLength.
NOTE: the extra nodes like ZeroLength appear in element property if they are
genereted by elements or in Analysis_step if they are generated by Conditions or
Analysis. In general, nodes are wroten where they are created.
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Figure 221. Script of all element properties

7. analysis_step: it can be considered a box in which it contains: constraints (in this case
fix constraint and equalDOF); Patterns (for loads, constraints and UniformExcitation);
misc_commands (region) and the last required step is the analysis command. This
structure may be repeated all times for another Analyses, like in the example below:
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1st Analysis Step

2nd Analysis Step
Step

NOTE: the 2nd Analysis uses the same recorder of the first.
Figure 222. All Analysis steps

NOTE: For a Parallel Analysis, it is important to set Parallel RMC on the number bar together with Mumps
system.
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2.9.4.3.
Run analysis
Once selected the solver, user can choose to write just an input file or run
directly the analysis. To run the analysis clik on Run analysis > in the main
toolbar. After clicking Run Analysis, STKO will automatically connect to
Opensees that will generate 7 files in ticle (.tcl), an .mpco.cdata file and an
.mpco file. The ticle (.tcl) files as already said are the description of the model
in order to be solved by Opensees. They are shered indeed in: main.tcl; definitions.tcl;
materials.tcl; sections.tcl; nodes.tcl; elements.tcl. The .mpco.cdata file is a file strictly
related to STKO and its interface, as it translates the graphical properties of the model
elaborated in the part of the pre processor and makes them visible also in the post-processor
section. In other words the .mpco data contains the whole, not required from Opensees,
graphical information to visualize the model to solve it. The .mpco file however is the in which
there is the solution of the model. This one will be loaded in the post processor session to
read the analysis output.

Figure 223.Example of creation of ticle, .mpco.cdata and .mpco files

The analysis toolbar has also another part with two drop down menues:

In the frist one are listed all the possible solvers to be used between OpenSees, OpenSeesMp
and OpenSeesSp.
Choosing OpenSees as solver will automatically determine the number of processors to be
used in the analysis.
Otherwise choosing OpenSeesMp the number of implied processor will be stated according
to the number of partition (Refer to § 2.8.8 Partition).
Choosing OpenSeesSp as a solver will activate the number processor drop down menu, in
qhich user can set the number processor to imply in the analysis.
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3. Postprocessing Module
With the Postprocessing Module, user can visualize results of analises though OpenSees
Databases. Results will be postprocessed by STKO Postprocessing Module through plots,
graphics, etc. with the following subchapters will gradually analyse the process.

3.1. Working with Databases
To Open an OpenSees Database from Post Processor interface, choose Document >
Open DB from the Toolbar or from the Work Tree panel, right-click on Databases and
Select Open DB.
Select MPC Output Database file (*.mpco).
From the Work Tree panel user can see the imported Database:

Figure 224. Creation of a new mpco output database

To close Database, choose Document > Close DB from the Toolbar, or right-click on
the Database from the Work Tree panel. Select Close Database:

Figure 225. STKO window to close the database

STKO
134

To reload the Database, choose Document > Reload DB from the Toolbar or right-click on the
Database from the Work Tree panel. Select Reload Database.

3.2. Creating Plot Groups
To analyse results in Postprocessing Module, user needs to create a Plot Group
before Plots. Choose the command Plot > New plot group from Toolbar or rightclick on Plot Groups from the Work Tree panel.
To deleta plot group choose the command Plot > Delete plot group from Toolbar
Or right-click on Plot Groups from the WorkTree panel. Select Delete Plot Groups.

Figure 226. Creation of the New Plot Group

3.2.1. Creating Plots
After load Database and create a Plot Group, user can generate a new Plot choosing between
Deformed Shape Plot, Surface Color Map Plot, Volume Color Map Plot, Vector Plot, Gauss
Point Plot and Fiber Section Plot.
3.2.2. Deformed Shape Plot
To create a Deformed Shape Plot, right-click on
New Plot Group from the Work Tree
panel or directly choose the command
Plot > Deformed Shape from the
Toolbar.
Select Deformed Shape to analyse the
model
Figure 227. Creation a Deformed Shape plot

deformation.

Click

on

item

Deformed Shape:
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All customizable information about Deformed Shape will appear from the Editor panel:

Modifying Deformation Scale to 20:

To Delete Plot, right-click on Deformation Shape > Delete Plot.
To Add new Plots to analyse, right-click on New Plot Group and choose the new Plot.
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3.2.3. Surface Color Map Plot
To create a Surface Color Map Plot, right-click on New Plot Group from the Work
Tree panel and Select Surface Color Map or choose the command Plot > Surface
Plot from the Toolbar

Figure 228. Creation of a Surface Color Map

All customizable information about Surface Color Map Plot will appear from the Editor
panel:

Figure 229. Editor of the Surface Color Map

To Delete Plot, right-click on Surface Color Map Plot > Delete Plot. To Add new Plots to
analyse, right-click on New Plot Group and choose the new Plot.
3.2.4. Volume Color Map Plot
To create a Volume Color Map Plot, right-click on New Plot Group from the Work
Tree panel and Select Volume Color Map or choose the command Plot > Volume
Plot from the Toolbar
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Figure 230. Creation of a Volume Color Map

All customizable information about Volume Color Map Plot will appear from the Editor
panel:

Figure 231. Editor of the Volume Color Map

To Delete Plot, right-click on Volume Color Map Plot > Delete Plot.
To Add new Plots, right-click on New Plot Group and choose the new Plot.
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3.2.5. Vector Plot
To create a Vector Plot, right-click on New Plot Group from the Work Tree panel and
Select Vector Plot or choose the command Plot > Vector Plot from the Toolbar.

Figure 232. Vector Point Plot

All customizable information about Vector Plot will appear from the Editor panel.
3.2.6. Gauss Point Plot
To create a Gauss Point Plot, right-click on New Plot Group from the Work Tree
panel and Select Gauss Point Plot or choose the command Plot > Gauss Plot from
the Toolbar.

Figure 233. Creation of the Gauss Point Plot

All customizable information about Gauss Point Plot will appear from the Editor panel:
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Figure 234. Editor of the Gauss Point Plot

To Delete Plot, right-click on Gauss Point Plot > Delete Plot.
To Add new Plots, right-click on New Plot Group and choose the new Plot.
3.2.7. Fiber Section Plot
To create a Fiber Section Plot, right-click on New Plot Group from the Work Tree
panel and Select Fiber Color Plot or choose the command Plot > Fiber Plot from
the Toolbar

Figure 235. Creation of the Fiber Color Map

All customizable information about Fiber Color Plot will appear from the Editor panel:
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Figure 236. Editor of the Fiber Color Map

STEEL

Figure 237. Selection of the steel material
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CONCRETE COVER

Figure 238. Selection of the concrete cover

CONCRETE CORE

Figure 239. Selection of the concrete core

To Delete Plot, right-click on Fiber Color Plot > Delete Plot.
To Add new Plots, right-click on New Plot Group and choose the new Plot.
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3.2.8. Animation
After defining Plots, STKO allows to record in a video the time steps of a post processor
model. Click on New Plot Group from the work tree and the Editor panel will activate the
Animation function:

.
-

Set the Start and the End of the time steps

-

Select the command register to save the path of the video.

-

Click on play to start the recording.

-

Play button will convert in record button.
It means that STKO is recording the

render

window.

Every

motion of the model will be recorded by STKO.
-

Click on pause button to interrupt the recording. The video will automatically save
in the path previously defined.

Also, user can choose if record the video with or without write info (Model stage Id, Plot
group id, Steps Id, Time), as follows:
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Figure 241. Video with information

Figure 240. Video without information

NOTE: To finalize the recording is important after the record to
save the Animation with name and format. After that a
compression video editing window will appear (also behind
the

SKTO

window!!!)

it

is

important

to

choose

the

compression program (Microsoft_RLE, Microsoft Video 1…)
and the quality of it otherwise animation won’t be recordered.
3.2.9. Managing tensor and vector results
In general, Opensees Elements do not export dynamic invariants. STKO overcomes this lack
thanks to the Post-Processor. Tresca, Von Mises, J2, Octahedral tension are calculated by
means with invariants:
SYMBOL
Ī 1ε

σtresca

DESCRIPTION
First modified invariant of Green strain
tensor
Second modified invariant of Green
strain tensor
Third modified invariant of Green strain
tensor
Tresca stress

σmises

Von Mises stress

тoct

Octahedral tension

Ī 2ε
Ī 3ε

EXPRESSION
Ī 1ε = ½ (Ī 1 – 3)
Ī 2ε = ¼ ((Ī 2 – 3) – 2(Ī 1 – 3))
Ī3ε = ⅛ ((Ī 1 – 3) – (Ī 2 – 3))
max(max(|σ1 − σ2, |σ2 − σ3|), |σ1 −
σ3|)
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The following example shows three types of geometries in Post-Processor: a Solid, a Shell and
a Beam element:

It is important to highlight how each geometry is associated to a result - e.i. E2 section force
(Surfaces):
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ELEMENT
Shell

VISUALIZATION

Fiber Plot

Varying the results (E1, E2, E3, E4, E9, ect.)
will only change the color map of
geometries which are interested to the
result.

Beam/Column
Fiber Plot

Solid
Face Plot

3.2.9.1. Local Result Orientation
In STKO, the results may be not only scalar but also vector and tensor. These results must
necessarily be expressed in a coordinate system. Vector and tensor results are oriented
according to three reference systems:

Generally, Opensees saves the results
in .mpco considering that:

Figure 242. Usual coordinate systems arranged according to the element

xg, yg, zg = Global Axes (default);xl,
yl, zl = Local Axes (user defined);
xel, yel, zel = Element Local (typically
of the element).

STKO
146

2D

3D

SOLID 2D
Results in Global System (ex. material.stress)

SOLID 3D
Results in Global System (ex. material.stress)

BEAM
Results in Local System (ex. section.force;
section.fiber.stress)

SHELL
Results in Element Local (ex. section.force;
section.fiber.stress)

BEAM
Results in Local System (ex. section.force;
section.fiber.stress)

To uniform the visualization of results, STKO visualizes the components of vector and tensor
results in the Local System. In particular:
Element

OpenSees

2D and 3D Solids

Global System

Global System

Beam

Local System

Local System

Shell

Element Local

STKO rotates axes according to Local
System
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The example below shows this important feature: two plates with same dimensions and same
reference system (global axes (x-y)) but with different element properties: a shell and a 3D
solid.

SHELL

3D ELEMENT with a vertical Pressure
Rotating the plates by 30°, the global axes remain unchanged in their initial configuration (xy):

30° rotation
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Even if elements are the same, user will find different results between non-rotated plates and
the rotated ones because the coordinate system is different because of the rotation. After
launching the Analysis, STKO Post-Processor will show these differences.

Figure 243. material.stress color map

Figure 244. section.fiber.stress color map

Only in the case of the invariants, results will be unchanged:
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On the other hand, results will be the same only if local axes will be orientated according to
the element orientation like in the following example:

Local Axes

Global Axes

After launching the Analysis, STKO Post-Processor will show that there are not differences in
results:
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3.3. Extracting Chart Data
Chart Data is another command that can be extracted and reloaded together with Database
and Plot Groups.
Right-click on Chart Data > Extract Chart Data.
3.3.1. Extracting Results on Nodes
A Chart Data Extraction Wizard will appear. It enables to choose the result type (1) and then
the result to extract (2) whose results depends on the previous choise (on nodes, on gauss or
on fibers).
After creating a Deformed Shape Plot or a Surface Color Map Plot, Select results On nodes:

1
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2
After choosing the result to extract, click on Next and Select the locations (nodes) for chart
data extraction. User can see the list of selected entities in the table:

Click on Next to assign a name to the Chart Data > Finish.
A new Chart is ready and visible in the Editor Panel and in the Work Tree:
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1

Chart Data on Work Tree also shows a list of plot data. Selecting one of nodes, user can see a
table with time step and Uy.
Chart graphically displays plot data that can be exported by user: click on Export Chart in
Editor Panel and choose the available format: PDF, SVG, Postscript Documents and Images.
3.3.2. Extracting Results on Gauss Points
After creating a Gauss Point Plot, user can extract results on Gauss Points:
Right-click on Chart Data > Extract Chart Data from Work Tree panel or from
Toolbar > Plot > Extract chart data.

Select > On element gauss points from Chart Data Extraction Wizard > Next:
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Select Gauss points on the model and data results to show. Click on Next to assign a name to
the Chart Data > Finish.

A new Chart is ready and visible in the Editor Panel and in the Work Tree:
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Chart graphically displays plot data that can be exported by user: click on Export Chart in
Editor Panel and choose the available format: PDF, SVG, Postscript Documents and Images.
3.3.3. Extracting Results on Fibers
After creating a Shell Fiber Color Map Plot, user can extract results on sub-gauss points
(fibers):
Right-click on Chart Data > Extract Chart Data from Work Tree panel or from
Toolbar > Plot > Extract chart data.

Select > On element sub-gauss points (fibers) from Chart Data Extraction Wizard > Next:

Select fibers on the model and data results to show. Click on Next to assign a name to the
Chart Data > Finish:

A new Chart is ready and visible in the Editor Panel and in the Work Tree:
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Chart graphically displays plot data that can be exported by user: click on Export Chart in
Editor Panel and choose the available format: PDF, SVG, Postscript Documents, and Images.
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4. Python Interface
Python is an interpreted, high-level, general-purpose programming language. As open source
software with a community-based development model it is used in the reference
implementation of STKO. The Python-based STKO interface extends the pre-processor
capabilities and generates user interface objects for the input data of the external solver. They
are, for instance, material properties, beam and shell cross sections, generic attributes, loads,
boundary conditions and analysis algorithms. To set this the user has to directly interact with
the programming language of Python.

4.1. How to interact with Python
….COMING SOON!
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5. General Examples
5.1.

Elastic Portal Frame

Elastic Portal Frame is a simple example to give an input format overview. Draw a simple
model of a 2D Portal on X-Y plan like in the example below:

Then set the Time Series from Definition Command:
Select Property > New Definition and then Model > timeSeries > Linear from the dropdown menus:
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Select OK to confirm the settings.

Then assign a New Physical Property. Select Property > New Physical Property > Model
from the Toolbar and choose sections > Elastic from the drop-drown menus:
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Define the type of 2D section with the Beam Section Editor window:

Define the type of 2D section with the Beam Section Editor window:
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Click on OK to confirm the settings. Assign the Beam Section to the entire model.
NOTE: It is necessary to define a Special Purpose if the model contains elements with more
physical properties. (See §3.8.3 Special Purpose for Physical Properties)
After that select Property > New element property > beam_column_element >
dispBeamColumn from the Toolbar:

Click on OK to confirm the settings and assign it to the entire model.
NOTE: It is necessary to define a Special Purpose if the model contains elements with more
element properties. (See §2.5.1 Special Purpose for Element Properties)
To define constaints select Condition > New Condition from the Toolbar; click on Model and
choose Contraints > sp > fix from the drop-down menus:
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Select the nodes on the base of the portal and then click on OK to confirm the settings.
To apply a constant load to the beam, create a load from Condition > New condition and
select Model > Loads > eleLoad > eleLoad_beamUniform from the drop-down menus:
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Select the top edge of the portal before confirming the settings:

After creating the model, define mesh size along the edge. Select Mesh > Global seed from
the Toolbar and set the global edge seed. The model is ready to be meshed:
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Once completed the model,define the analysis:
The first Analysis step is the Recorder. Right click on Analysis Step > Add from the Work
Tree. Choose Recorders > MPCORecorder from the drop-down menus.

Click on the three-point button to
specify the path and the name of
MPCORecorder

Check the box to select the nodal
results and element results to write in
the Recorder

Click on OK to confirm the settings.
NOTE: It is important to define Patterns and Recorders before the Analyses.

Now define the Pattern and the Analysis steps.
Righ click on Analysis steps > Add from the Work Tree:
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The pattern plain is complementary to the
previous settings:
tsTag = insert Time Series;
load = insert force;
eleLoad = insert eleLoad (i.e. eleLoad);
sp = insert displacement on single point

After setting, all the parameters need to analyse. Click on OK to confirm them.
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The last step is to add an Analysis. Right click on Analysis Step > Add from the Work Tree.
Choose Analyses > Analyses Command from the drop-down menus and set all the
attributes from the Analysis Step Editor:

Insert from 1 to n number
of analysis steps to
perform

Click on OK to confirm the settings.
All the Analyses steps are completed and ready to be exported in ticol files (.tcl).
Click on run analysis and automatically the software connects to Opensees that will analyse all
the inputs from STKO and will generate a .mpco file to be analysed in STKO Post Processor:
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5.2.

Fiber Portal Frame

Draw a simple model of a 2D Portal on X-Y plan like in the example below:

To create Physical Properties, choose Property > New Physical Property and select an
uniaxial material (i.e. Concrete01):
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Type values to attribute to the Concrete
Core. Each attribute has a link to
Opensees website and a short
description of them.
Click on OK to confirm the setting.

Do the same process for the Cover Concrete always choosing, for instance, an uniaxial
concrete material: Concrete 01. Set all parameters and confirm them.
It is also important to define a third material, Steel01 from the Steel and Reinforcing-Steel
Materials:

After defining Materials click on Property > New physical property from the Toolbar to
create a Fiber Beam Cross-Section otherwise directly right click on Physical properties >
Add from the Work Tree Panel. Then the physical property Model can be choosen from the
new interface. Click on sections from the drop-drown menu and select Fiber:
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Draw a rectangular column (for example 600x380 mm) in the Beam Fiber Section Editor.
Follow all the steps previously shown §3.8.2.2. Fiber Beam Cross-Sections. Therefore, assign
Concrete Core, Cover Concrete and Rebar to the section:

Rename the Beam Fiber Section and confirm it.
NOTE: create a Special Purpose from Physical Properties only if necessary.
Select Property > New Physical Property > special_purpose > Beam-Column >
BeamSectionProperty:
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Select the interaction type and the sectionTag to
attribute. Click OK to confirm the setting. Assign it to
the model after selecting the geometry.

Then assign another New Physical Property. Select Property > New Physical Property >
Model from the Toolbar and choose sections > Elastic from the drop-drown menus:

Define the type of 3D section with the Beam Section Editor window:
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Click on OK to confirm the settings.It is now necessary to create new element properties.
Choose Property > New element property > Model and select forceBeamColumn from
beam_column_elements:

Assign ForceBeamColumn and the Fiber Section to the beam. Same process for the new
element elasticBeamColumn:
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It will assign to the columns together with Elastic Section:

Fiber Section +
ForceBeamColumn

Elastic Section +
elasticBeamColumn

STKO
174

After that, create a constraint to apply to the base (fix constraint). Choose Condition > New
Condition from the main Toolbar.

Before confirm the Condition Editor, select the nodes to the base and click on OK to assign
the setting.
Then add a force to the nodes of the beam (NodeForce) from Condition > New Condition.
Select Model > Loads > Force > NodeForce from the drop-down menus.
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Before confirm the Condition Editor, select the nodes of the beam and click on OK to assign
the setting.

It is now possible to set the Time Series from Definition Command:
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Select Property > New Definition and then Model > timeSeries > Linear from the dropdown menus.
After defining new physical and element properties, loads and constraints, now create
Patterns that compose the Analysis steps. Righ-click on Analysis steps > Add from the Work
Tree:

Then define mesh size along the edge. Select Mesh > Global seed from the Toolbar and set
the global edge seed with the type and size. The model is ready to be meshed:
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The pattern plain (like other
patterns:
MultipleSupport,
UniformExcitation,
patternContraint,
patternPlain)
depends
on
previous settings:

tsTag = insert Time Series;
load =
insert
NodeForce);

force

(i.e.

eleLoad = insert eleLoad;
sp = insert displacement on
single point.

After setting all the parameters need to be analysed. Click on OK to confirm them.
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The second Analysis step is the Recorder. Right-click on Analysis Step > Add from the Work
Tree. Choose Recorders > MPCORecorder from the drop-down menus.

Click on the three-point button to
specify the path and the name of
MPCORecorder

Check the box to select the nodal
results and element results to write in
the Recorder

Click on OK to confirm the settings.
NOTE: It is important to define Patterns and Recorders before the Analyses.
The last step is to add an Analysis. Right-click on Analysis Step > Add from the Work Tree.
Choose Analyses > Analyses Command from the drop-down menus and set all the
attributes from the Analysis Step Editor:
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Insert from 1 to n number
of analysis steps to perform

Click on OK to confirm the settings.
All the Analyses steps are completed and ready to be exported in ticol files (.tcl).
Click on run analysis and automatically the software connects to Opensees that will analyse all
the inputs from STKO and will generate a .mpco file to be analysed in STKO Post Processor.

STKO
180

5.3.

Shear Frame

Draw a simple model of a 2D Portal on X-Y plan and create an Interaction “Node to Node
link” like in the example below:

Slave Geometries (node3)

Master Geometry (node1)

To create an Interaction select Geometry-Interaction > New interaction > choose Node to
Node links. Click on OK to confirm the Interaction and then select master geometries for the
interaction (node 1 and node 2 in this case). The geometrical model is now complete and
ready to be meshed.
After that, select Condition > New Condition > Contraints > sp > fix from the main Toolbar
and set the Condition editor with the following settings:

1

Select the node to the base and then click on OK to confirm the settings.
Now create another New Condition > Contraints > mp > equalDOF and set the Condition
editor with the following settings:
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Select the Interaction and assign the equalDOF to the brace.
Create the last Condition selecting New Condition > Mass > EdgeMass and set the Condition
editor with the following settings:

Select the Portal and assign the EdgeMass to it.
After that, define the Physical Property of the model: select Property > New Physical
Property > sections > Elastic and set the Physical Property editor with the following settings:
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Create a Beam Section_I infinitely large:

Select OK to confirm the settings and assign the Elastic Section to the Portal
Add another Physical Property for the brace. Select Property > New Physical Property >
materials > uniaxial > Other Uniaxial Materials > ViscousDamper and set the Physical
Property Editor like following:
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Click on OK to confirm the settings. After creating a ViscousDamper, it is important to define a
Special Purpose with the following settings:
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Click on OK to confirm the setting and then assign the special purpose to the interaction with
the support of the Quick access Toolbar:

TO ONLY SELECT:

vertexes edges faces solids all interaction

NOTE: To check that all the physical properties are successfully assign to the element of the
model, do not forget to set the Shader that is on the Editor:

Doing this, it is possibile to see the correct physical property assignment thanks to the
selection Color by that is in the Property from the main Toolbar.
After that, it is necessary to define New Element Properties. Select Property > New
element property > beam_column_element > elasticBeamColumn:
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Click on OK to confirm the Physical Element Property Editor and assign it to the Portal.
Also, define a link_element from Property > New element property > link_element >
twoNodeLink:

Click on OK and assign it to the interaction.
Before defining the Analysis step, needs to define a Time Series. Select Property > New
Definition > timeSeries > Path:
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Check the box to activate -factor

Insert a list of factor values
Time interval between specified points

A factor to multiply load factors by
(0,50xg)

After the definition of all the steps as seen before, create Patterns that compose the Analysis
steps. Righ-click on Analysis steps > Add and choose Pattern Constraint:
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Insert fix constraint
previously defined
Insert equalDOF

Click on OK to confirm the setting. Now add a second Pattern: UniformExcitation:

Insert time series
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Click on OK to confirm the settings. It is now necessary to add a Recorder selecting Analysis
steps > Add from the Work Tree and set the Analysis Step editor with the following settings:

The last step is to create an Analysis with the following settings:
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Click on OK to confirm the settings.
Now the analysis is ready to be launched and exported in ticol files (.tcl).
Click on run analysis and automatically the software connects to Opensees that will analyse all
the inputs from STKO and will generate a .mpco file to be analysed in STKO Post Processor.
Move to Post Processor interface to load the new database. Select Open DB from the main
Toolbar or right-click to Databases > Add. Select the file .mpco previously created.
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Even if the DB is correctly open, it is
necessary to create a New Plot Group
to see the model in post processor

Right-click on Plot Groups > New Plot Group from the work tree panel, otherwise directly
select Plot > New plot group from the main Toolbar and choose the Plot to analyse
(Deformed Shape, Surface Color Map, Volume Color Map, Beam/Shell Fiber Color Map
and Gauss Point Plot):

Set the type of Deformation (Displacement) the Deformation scale (default 1 but in this
case 20.00) and the Time step previously defined in pre-processor:
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To add new Plots, right-click on New Plot Group and select the new Plot:
All customizable information about the New Plot
Group appear from the Editor panel on the right:

STKO
192

Advanced Modeling Examples
Bridge Modeling

Figure 245.Example of bridge modeling

Figure 246.Partial model view

Figure 247.Partial model view

Figure 248.Earth interaction beamSolidCoupling

Figure 249.Pile

Figure 251.Hinged beam element application

Figure 250.Rigid link application to pile
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Figure 252.Example of column modeling

Figure 253.DistributedLK3D

Figure 254.Pile fiber section
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Figure 255.Post-processor analysis

Figure 256.Post-processor various plots
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Residencial tower modeling

Figure 258.Detail of geometries

Figure 257.Geometries construction

Figure 260.Element attribution:
beam column, ShellMITC4 and
ZeroLength.

Figure 259.Physical properties attribution.
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Figure 261.Meshing model

Figure 262.Post processor plot
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